Bug 1376324

Summary: root is not built for aarch64
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: rootAssignee: Mattias Ellert <mattias.ellert>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mattias.ellert, steve.traylen
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: aarch64   
OS: Unspecified   
URL: https://sft.its.cern.ch/jira/browse/ROOT-7291
Whiteboard:
Fixed In Version: root-6.08.02-1.fc25 root-6.08.02-1.fc24 root-6.08.02-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-24 05:40:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1405570    
Bug Blocks: 245418, 1392467    
Attachments:
Description Flags
build logs none

Description Petr Pisar 2016-09-15 05:45:26 UTC
After merging aarch64 packages into F26 primary koji, root package is not there. Please rebuild this package to provide the aarch64 build. It was supported in F23 (bug #1263206).

Comment 1 Petr Pisar 2016-09-23 10:46:09 UTC
Created attachment 1204099 [details]
build logs

I tried a scratch build from dist-git master branch (193d74d76af544701f441bd5f5405fcd3e407c7a) and tests fail on segmenation fault.

Comment 2 Fedora Update System 2016-12-08 21:15:09 UTC
root-6.08.02-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5112b85682

Comment 3 Fedora Update System 2016-12-08 21:15:17 UTC
root-6.08.02-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b9bcffe964

Comment 4 Fedora Update System 2016-12-08 21:15:22 UTC
root-6.08.02-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-78260ff5fb

Comment 5 Petr Pisar 2016-12-09 06:14:14 UTC
Excuse me, but the root-6.08.02-1.fc25 build is still not available for aarch64.

Comment 6 Fedora Update System 2016-12-10 03:56:40 UTC
root-6.08.02-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5112b85682

Comment 7 Fedora Update System 2016-12-10 04:28:36 UTC
root-6.08.02-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b9bcffe964

Comment 8 Fedora Update System 2016-12-10 05:53:37 UTC
root-6.08.02-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-78260ff5fb

Comment 9 Petr Pisar 2016-12-12 07:59:00 UTC
Could you please remove this bug number from the update?

Comment 10 Mattias Ellert 2016-12-12 09:49:36 UTC
Please provide some motivation for that. This update fixes the issue that the package is not buildable on aarch64, so I think it is perfectly fine to indicate in the update that it fixes this bug. Actually I think it is the right thing to do, and not doing it would be incorrect.

Comment 11 Petr Pisar 2016-12-12 09:58:52 UTC
Maybe the code is buildable, but it's not built <https://koji.fedoraproject.org/koji/buildinfo?buildID=823482> for aarch64. This is what this bug is about. It affects all root reverse dependencies because they now have to exclude aarch64 too.

Comment 12 Fedora Update System 2016-12-19 06:01:59 UTC
root-6.08.02-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-12-19 07:52:30 UTC
root-6.08.02-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Mattias Ellert 2016-12-24 21:21:05 UTC
(In reply to Petr Pisar from comment #5)
> Excuse me, but the root-6.08.02-1.fc25 build is still not available for
> aarch64.

For F25, aarch64 builds are not done in the main koji, but in the arm-koji. The aarch64 build has not yet been attempted even though the build in the main koji happened more than two weeks ago, and is now stable.

I did submit a scratch build for F25 to the arm-koji:

https://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3786793

This build was successful, in-as-much the state is closed, and all the subtasks reported successful completion. However the build.log shows the same errors during the extraction of debuginfo that the rawhide build does on the main koji, and downloading the debuginfo rpm and examining it shows it is broken the same way as on rawhide. (See bug #1405570)

So the build succeeds on aarch64, and the test suite runs without errors. But there is some issue with the creation of the debuginfo rpm.

The aarch64 build on EPEL 7 does not suffer fron this problem:

https://koji.fedoraproject.org/koji/buildinfo?buildID=823484

Comment 15 Fedora Update System 2016-12-25 05:49:43 UTC
root-6.08.02-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Petr Pisar 2017-01-02 09:15:07 UTC
I see. Then let's wait for a successful F26 build.

Comment 17 Mattias Ellert 2017-01-24 05:40:44 UTC
The bug in rpm that caused the aarch64 debuginfo package to be broken and the build to fail has been fixed in rawhide (rpm-4.13.0-11.fc26). The build of root in rawhide has now succeeded (root-6.08.04-1.fc26) using this new version of rpm.