Bug 137677

Summary: Gcalctool can't do ^(1/3) for negative numbers
Product: [Fedora] Fedora Reporter: Need Real Name <supercat>
Component: gnome-utilsAssignee: Marco Pesenti Gritti <mpg>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 2   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-04 13:12:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2004-10-30 15:00:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10.1

Description of problem:
(-27)^(1/3) should be -3. However, it can't be calculated with Gcalctool.
I typed the sequence:

27
(+/-)
^
3
(1/x)
=

the Gcalctool then show ERROR


The problem seems to be solved in Gcalctool 5.5.0

Version-Release number of selected component (if applicable):
gnome-utils-2.6.0-2

How reproducible:
Always

Steps to Reproduce:
1. Do the calcuation

    

Actual Results:  ERROR (I am using Chinese, so indeed the error is in
Chinese)

Expected Results:  -3 for (-27)^(1/3)

Additional info:

Comment 1 Marco Pesenti Gritti 2004-11-04 13:12:19 UTC
UPSTREAM

http://bugzilla.gnome.org/show_bug.cgi?id=157021