Bug 1377395 (sbcl-aarch64)

Summary: sbcl packages don't exist for aarch64 and ppc64(LE)
Product: [Fedora] Fedora Reporter: Matt Chan <talcite>
Component: sbclAssignee: Rex Dieter <rdieter>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: green, rdieter, talcite, than
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-29 14:10:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 238953, 245418, 1071880, 922257, 1380102    

Description Matt Chan 2016-09-19 14:53:59 UTC
Description of problem:
SBCL doesn't have packages for aarch64 and ppc64(LE)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Rex Dieter 2016-09-19 15:48:20 UTC
Upstream *claims* aarch64 is supported, 
http://www.sbcl.org/platform-table.html
(ppc64, not so much)


but the last time I tried bootstrapping a build, it failed miserably.

Hopefully, I can find some time to try again soon.

Comment 2 Peter Robinson 2016-09-28 18:47:54 UTC
> but the last time I tried bootstrapping a build, it failed miserably.

I tried aarch64 and the bootstrap binaries crashed on f24 even running basic bits

Comment 3 Ngo Than 2017-03-29 14:10:09 UTC
i added aarch64 support in sbcl-1.3.16-2.fc27.

https://koji.fedoraproject.org/koji/buildinfo?buildID=873805