Bug 1377763

Summary: [RFE] metric calculation job dispatch optimization
Product: Red Hat OpenStack Reporter: Julien Danjou <jdanjou>
Component: openstack-gnocchiAssignee: Julien Danjou <jdanjou>
Status: CLOSED ERRATA QA Contact: Mehdi ABAAKOUK <mabaakou>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 10.0 (Newton)CC: apevec, fbaudin, jschluet, lhh, mabaakou, mlopes, nlevinki, pkilambi, rhos-flags, sclewis
Target Milestone: rcKeywords: FutureFeature, Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-gnocchi-3.0.0-1.el7ost Doc Type: Release Note
Doc Text:
With Gnocchi 2.2, job dispatch is coordinated between controllers using Redis. As a result, you can expect improved processing of Telemetry measures.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 16:02:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1394648    
Attachments:
Description Flags
Test plan and its results
none
Test plan and its results none

Description Julien Danjou 2016-09-20 14:45:20 UTC
Starting with Gnocchi 2.2, a new job dispatching using coordination (Redis) is done, so better and faster processing of measures happen.

We want to make sure that works correctly.

Comment 2 Pradeep Kilambi 2016-09-23 12:38:34 UTC
missing Fixed in version info, moving to post until we have gnocchi 3.0 in brew

Comment 6 Mehdi ABAAKOUK 2016-10-20 12:40:54 UTC
Created attachment 1212508 [details]
Test plan and its results

Comment 7 Mehdi ABAAKOUK 2016-10-20 12:43:30 UTC
Created attachment 1212510 [details]
Test plan and its results

Comment 9 errata-xmlrpc 2016-12-14 16:02:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html