Bug 1378151

Summary: [RFE][nova]: Virtual guest device role tagging (cont.)
Product: Red Hat OpenStack Reporter: Stephen Gordon <sgordon>
Component: openstack-novaAssignee: Artom Lifshitz <alifshit>
Status: CLOSED ERRATA QA Contact: awaugama
Severity: low Docs Contact:
Priority: low    
Version: 10.0 (Newton)CC: alifshit, berrange, dasmith, eglynn, jjung, jschluet, kchamart, mgarciam, nlevinki, panbalag, rnoriega, sbauza, sclewis, sferdjao, sgordon, srevivo, vromanso
Target Milestone: Upstream M2Keywords: FutureFeature, Triaged
Target Release: 13.0 (Queens)Flags: panbalag: needinfo+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-nova-17.0.0-0.20180223162252.a4a53bf.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:26:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1235009, 1419948, 1442136, 1732816, 1419231    

Description Stephen Gordon 2016-09-21 15:22:51 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/virt-device-role-tagging.

Description:

This will provide a mechanism for the user to tag a device they have assigned to their guest with a specific role. The tag will be matched to the hardware address of the device and this mapping exposed to the guest OS via metadata service/cloud-init.

Specification URL (additional information):

http://specs.openstack.org/openstack/nova-specs/specs/mitaka/approved/virt-device-role-tagging.html

Comment 1 Stephen Gordon 2016-09-21 15:26:49 UTC
Driving use case was addressed in Newton, cloned to address technical debt follow-ups in Ocata.

Comment 2 Stephen Gordon 2016-09-27 13:39:38 UTC
Dropping https://blueprints.launchpad.net/nova/+spec/virt-device-role-tagging from the URL for now as because we are re-using the same blueprint the bot is going to continue to get the status wrong.

Comment 7 Stephen Gordon 2016-12-20 21:58:17 UTC
Hi Artom,

Where can I find the Ocata era code reviews?

Thanks,

Steve

Comment 9 Artom Lifshitz 2016-12-23 05:17:26 UTC
Stephen,

The gerrit topic is virt-device-tagged-attach-detach [1] (dunno why I put detach there, but what's done is done).

[1] https://review.openstack.org/#/q/topic:bp/virt-device-tagged-attach-detach

Comment 10 Artom Lifshitz 2017-01-09 20:04:54 UTC
Quick status update: work is progressing upstream. Cautiously optimistic that we can merge this for Ocata, even though spec has been classified as 'slow progress/at risk' [1] by the PTL (Matt). It's not clear to me Matt is aware of the presence of a Tempest test [2], and there has been some reviewer attention o n the patches, including from Matt himself.

[1] https://etherpad.openstack.org/p/nova-ocata-feature-freeze
[2] https://review.openstack.org/#/c/391947/

Comment 14 Stephen Gordon 2017-06-15 18:07:07 UTC
Moving to Queens as it seems likely at least some of these cleanup patches will still be outstanding.

Comment 16 Eoghan Glynn 2017-07-11 12:26:41 UTC
Setting to POST as all patches are landed:

https://review.openstack.org/#/q/topic:bp/virt-device-role-tagging

Comment 22 errata-xmlrpc 2018-06-27 13:26:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086