Bug 1379948

Summary: SELinux is preventing chronyd from 'read' accesses on the file hosts.
Product: [Fedora] Fedora Reporter: kakoskin
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: dominick.grift, dwalsh, lvrabec, mgrepl, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:449835002b11a3a2f5dc576d5d52e2b3c822dd0e90240674d53c578e60fa6e12;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-29 21:16:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description kakoskin 2016-09-28 08:19:47 UTC
Description of problem:
This error is related to automatic process on a freshly installed system with updates testing. I have not changed ntp configuration from default.
SELinux is preventing chronyd from 'read' accesses on the file hosts.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that chronyd should be allowed read access on the hosts file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'chronyd' --raw | audit2allow -M my-chronyd
# semodule -X 300 -i my-chronyd.pp

Additional Information:
Source Context                system_u:system_r:chronyd_t:s0
Target Context                system_u:object_r:fusefs_t:s0
Target Objects                hosts [ file ]
Source                        chronyd
Source Path                   chronyd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-191.17.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.7.4-200.fc24.x86_64 #1 SMP Thu
                              Sep 15 18:42:09 UTC 2016 x86_64 x86_64
Alert Count                   8
First Seen                    2016-09-27 17:30:41 EEST
Last Seen                     2016-09-28 09:37:31 EEST
Local ID                      4ddcd585-598c-42b5-ba1c-4b60df7c55c6

Raw Audit Messages
type=AVC msg=audit(1475044651.622:188): avc:  denied  { read } for  pid=1623 comm="chronyd" name="hosts" dev="dm-1" ino=1966632 scontext=system_u:system_r:chronyd_t:s0 tcontext=system_u:object_r:fusefs_t:s0 tclass=file permissive=0


Hash: chronyd,chronyd_t,fusefs_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-191.17.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.7.4-200.fc24.x86_64
type:           libreport

Comment 1 kakoskin 2016-09-29 21:16:50 UTC
Apologies, this was caused by a mislabeled file.