Bug 1380126

Summary: python-nipy FTBFS due to test failures (test_FIAC)
Product: [Fedora] Fedora Reporter: Dominik 'Rathann' Mierzejewski <dominik>
Component: python-nipyAssignee: Igor Gnatenko <ignatenko>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ignatenko, neuro-sig, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://github.com/nipy/nipy/issues/407
Whiteboard:
Fixed In Version: python-nipy-0.4.1-1.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-12 14:59:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dominik 'Rathann' Mierzejewski 2016-09-28 17:31:59 UTC
Description of problem:
There are three test failures in python-nipy test suite preventing successful build.

Version-Release number of selected component (if applicable):
python-nipy-0.4.0-5.fc25

How reproducible:
Always.

Steps to Reproduce:
1. fedpkg clone rpms/python-nipy
2. cd python-nipy
3. fedpkg build --scratch --nowait

Actual results:
======================================================================
ERROR: nipy.modalities.fmri.fmristat.tests.test_FIAC.test_altprotocol
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/fmristat/tests/test_FIAC.py", line 220, in test_altprotocol
    block, bT, bF = protocol(descriptions['block'], 'block', *delay.spectral)
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/fmristat/tests/test_FIAC.py", line 89, in protocol
    utils.events(times[k], f=h))
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/utils.py", line 341, in events
    e = e + g.subs(asymb, a) * f(T-time)
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 720, in __new__
    obj = super(AppliedUndef, cls).__new__(cls, *args, **options)
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 392, in __new__
    return result.evalf(mlib.libmpf.prec_to_dps(pr))
  File "/usr/lib/python2.7/site-packages/sympy/core/evalf.py", line 1385, in evalf
    result = evalf(self, prec + 4, options)
  File "/usr/lib/python2.7/site-packages/sympy/core/evalf.py", line 1284, in evalf
    re, im = x._eval_evalf(prec).as_real_imag()
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 468, in _eval_evalf
    return Float(self._imp_(*self.args), prec)
  File "/usr/lib64/python2.7/site-packages/scipy/interpolate/polyint.py", line 78, in __call__
    x, x_shape = self._prepare_x(x)
  File "/usr/lib64/python2.7/site-packages/scipy/interpolate/polyint.py", line 90, in _prepare_x
    x = _asarray_validated(x, check_finite=False, as_inexact=True)
  File "/usr/lib64/python2.7/site-packages/scipy/_lib/_util.py", line 231, in _asarray_validated
    raise ValueError('object arrays are not supported')
ValueError: object arrays are not supported

======================================================================
ERROR: nipy.modalities.fmri.fmristat.tests.test_FIAC.test_agreement
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/fmristat/tests/test_FIAC.py", line 277, in test_agreement
    X, c, D = create_protocols()
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/fmristat/tests/test_FIAC.py", line 204, in create_protocols
    block, bTcons, bFcons = protocol(descriptions['block'], 'block', *delay.spectral)
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/fmristat/tests/test_FIAC.py", line 89, in protocol
    utils.events(times[k], f=h))
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/utils.py", line 341, in events
    e = e + g.subs(asymb, a) * f(T-time)
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 720, in __new__
    obj = super(AppliedUndef, cls).__new__(cls, *args, **options)
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 392, in __new__
    return result.evalf(mlib.libmpf.prec_to_dps(pr))
  File "/usr/lib/python2.7/site-packages/sympy/core/evalf.py", line 1385, in evalf
    result = evalf(self, prec + 4, options)
  File "/usr/lib/python2.7/site-packages/sympy/core/evalf.py", line 1284, in evalf
    re, im = x._eval_evalf(prec).as_real_imag()
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 468, in _eval_evalf
    return Float(self._imp_(*self.args), prec)
  File "/usr/lib64/python2.7/site-packages/scipy/interpolate/polyint.py", line 78, in __call__
    x, x_shape = self._prepare_x(x)
  File "/usr/lib64/python2.7/site-packages/scipy/interpolate/polyint.py", line 90, in _prepare_x
    x = _asarray_validated(x, check_finite=False, as_inexact=True)
  File "/usr/lib64/python2.7/site-packages/scipy/_lib/_util.py", line 231, in _asarray_validated
    raise ValueError('object arrays are not supported')
ValueError: object arrays are not supported

======================================================================
ERROR: nipy.modalities.fmri.fmristat.tests.test_FIAC.test_event_design
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/case.py", line 197, in runTest
    self.test(*self.arg)
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/fmristat/tests/test_FIAC.py", line 299, in test_event_design
    Xblock, cblock = design.event_design(block[bkeep], t, hrfs=delay.spectral)
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/design.py", line 183, in event_design
    term = events(event_spec['time'], amplitudes=e_X[n], f=h)
  File "/builddir/build/BUILD/nipy-0.4.0/build/lib.linux-x86_64-2.7/nipy/modalities/fmri/utils.py", line 341, in events
    e = e + g.subs(asymb, a) * f(T-time)
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 720, in __new__
    obj = super(AppliedUndef, cls).__new__(cls, *args, **options)
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 392, in __new__
    return result.evalf(mlib.libmpf.prec_to_dps(pr))
  File "/usr/lib/python2.7/site-packages/sympy/core/evalf.py", line 1385, in evalf
    result = evalf(self, prec + 4, options)
  File "/usr/lib/python2.7/site-packages/sympy/core/evalf.py", line 1284, in evalf
    re, im = x._eval_evalf(prec).as_real_imag()
  File "/usr/lib/python2.7/site-packages/sympy/core/function.py", line 468, in _eval_evalf
    return Float(self._imp_(*self.args), prec)
  File "/usr/lib64/python2.7/site-packages/scipy/interpolate/polyint.py", line 78, in __call__
    x, x_shape = self._prepare_x(x)
  File "/usr/lib64/python2.7/site-packages/scipy/interpolate/polyint.py", line 90, in _prepare_x
    x = _asarray_validated(x, check_finite=False, as_inexact=True)
  File "/usr/lib64/python2.7/site-packages/scipy/_lib/_util.py", line 231, in _asarray_validated
    raise ValueError('object arrays are not supported')
ValueError: object arrays are not supported

----------------------------------------------------------------------
Ran 2599 tests in 187.772s

FAILED (SKIP=1, errors=3)

Expected results:
No test failures.

Additional info:
It looks like this was filed upstream already: https://github.com/nipy/nipy/issues/407 .

Comment 1 Igor Gnatenko 2016-09-29 06:20:21 UTC
As pointed out by upstream developer, looks like some bug in SciPy/SymPy