Bug 1382768

Summary: My Filters in datastores are not shown
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: UI - OPSAssignee: Hilda Stastna <hstastna>
Status: CLOSED ERRATA QA Contact: Matouš Mojžíš <mmojzis>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.6.0CC: cpelland, dajohnso, dclarizi, hkataria, jhardy, mpovolny, obarenbo, simaishi
Target Milestone: GAKeywords: ZStream
Target Release: 5.7.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ui:filter:datastore
Fixed In Version: 5.7.1.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1361224 Environment:
Last Closed: 2017-02-27 19:13:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1361224    
Bug Blocks:    

Comment 2 Matouš Mojžíš 2016-10-11 12:21:34 UTC
It is still not working as expected.
I can see added filters in My Filters after refresh...Not immediately after creating filter. It should be visible after creating it as it is anywhere else.

Comment 3 Satoe Imaishi 2016-11-23 14:59:49 UTC
Matous, can you please open a new BZ for filters showing only after refresh?  The original issue is fixed and we'd like to track the remaining issue separately.  Talked to DanC.

Comment 4 Matouš Mojžíš 2016-11-25 18:17:45 UTC
Hah, I tried it again on 5.7.0.12 and it stopped showing even after refresh.

Comment 11 CFME Bot 2017-01-16 13:47:56 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/952f11c688da8c85a56f306c47d6b3ec07f93596

commit 952f11c688da8c85a56f306c47d6b3ec07f93596
Author:     Hilda Stastna <hstastna>
AuthorDate: Mon Jan 9 13:31:08 2017 +0100
Commit:     Hilda Stastna <hstastna>
CommitDate: Mon Jan 9 13:31:08 2017 +0100

    Make visible My Filters in Datastores
    
    fixing
    https://bugzilla.redhat.com/show_bug.cgi?id=1398748
    https://bugzilla.redhat.com/show_bug.cgi?id=1382768
    
    Make created filters (not global) in Compute -> Infrastructure ->
    -> Datastores visible under My Filters in accordion.

 app/presenters/tree_builder_storage.rb | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

Comment 12 CFME Bot 2017-01-16 13:48:07 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/b0f99dfc7b497965d02d0c2daae2535de2e4f8ad

commit b0f99dfc7b497965d02d0c2daae2535de2e4f8ad
Author:     Hilda Stastna <hstastna>
AuthorDate: Mon Jan 9 13:39:33 2017 +0100
Commit:     Hilda Stastna <hstastna>
CommitDate: Mon Jan 9 13:39:33 2017 +0100

    Display new filter in Datastores right after creating it
    
    fixing
    https://bugzilla.redhat.com/show_bug.cgi?id=1398748
    https://bugzilla.redhat.com/show_bug.cgi?id=1382768
    
    Display a new filter (not global) in Compute -> Infrastructure ->
    -> Datastores in My Filters in accordion right after creating it,
    no need to refresh the page to see the new filter there.

 app/controllers/application_controller/filter.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 13 Hilda Stastna 2017-01-30 14:15:07 UTC
this bug is fixed by https://github.com/ManageIQ/manageiq/pull/13621

Comment 14 Matouš Mojžíš 2017-01-31 11:50:56 UTC
Verified in 5.7.1.0. Filter is shown in the tree view after creating.

Comment 16 errata-xmlrpc 2017-02-27 19:13:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2017-0320.html