Bug 1383730

Summary: Overcloud deploy with Swift and Cinder nodes fails with ERROR: Failed to validate: Failed to validate: resources[0]: The Resource Type (OS::TripleO::SwiftStorage::Ports::ManagementPort) could not be found
Product: Red Hat OpenStack Reporter: Dan Yasny <dyasny>
Component: openstack-tripleo-heat-templatesAssignee: Paul Grist <pgrist>
Status: CLOSED ERRATA QA Contact: Omri Hochman <ohochman>
Severity: high Docs Contact:
Priority: unspecified    
Version: 10.0 (Newton)CC: cschwede, dbecker, egafford, jjoyce, jschluet, mabrams, mburns, mcornea, morazi, rhel-osp-director-maint, sasha, scohen, shardy, thiago
Target Milestone: rcKeywords: Triaged
Target Release: 10.0 (Newton)   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.1.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-14 16:15:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dan Yasny 2016-10-11 15:38:01 UTC
Description of problem:
Deploying the overcloud
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --swift-storage-scale 1 --block-storage-sc
ale 1 --neutron-tunnel-types vxlan,gre --neutron-network-type vxlan,gre --neutron-network-vlan-ranges datacentre:118:
143 --neutron-bridge-mappings datacentre:br-ex --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tri
pleo-heat-templates/environments/puppet-pacemaker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/st
orage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-
environment.yaml --ceph-storage-scale 1
Removing the current plan files
Uploading new plan files
Started Mistral Workflow. Execution ID: 0e7164f5-de3b-4acf-a7b5-3e342df6279b
Plan updated
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
Started Mistral Workflow. Execution ID: 4bcf40b7-780a-4f96-b122-2c70af021eb2
{u'execution': {u'id': u'4bcf40b7-780a-4f96-b122-2c70af021eb2',
                u'input': {u'container': u'overcloud',
                           u'queue_name': u'dcc87f48-c6a3-42e4-9fe9-8ded54f4b9a0',
                           u'timeout': 90},
                u'name': u'tripleo.deployment.v1.deploy_plan',
                u'params': {}, 
                u'spec': {u'input': [u'container',
                                     {u'timeout': 240},
                                     {u'queue_name': u'tripleo'}],
                          u'name': u'deploy_plan',
                          u'tasks': {u'copy_validation_ssh_keys': {u'name': u'copy_validation_ssh_keys',
                                                                   u'on-complete': u'send_message',
                                                                   u'type': u'direct',
                                                                   u'version': u'2.0',
                                                                   u'workflow': u'tripleo.validations.v1.copy_ssh_key'},
                                     u'deploy': {u'action': u'tripleo.deployment.deploy timeout=<% $.timeout %> container=<% $.container %>',
                                                 u'name': u'deploy',
                                                 u'on-error': u'set_deployment_failed',
                                                 u'on-success': u'test_validations_enabled',
                                                 u'type': u'direct',
                                                 u'version': u'2.0'},
                                     u'send_message': {u'action': u'zaqar.queue_post',
                                                       u'input': {u'messages': {u'body': {u'payload': {u'execution': u'<% execution() %>',
                                                                                                       u'message': u"<% $.get('message', '') %>",
                                                                                                       u'status': u"<% $.get('status', 'SUCCESS') %>"},
                                                                                          u'type': u'tripleo.deployment.v1.deploy_plan'}},
                                                                  u'queue_name': u'<% $.queue_name %>'},
                                                       u'name': u'send_message',
                                                       u'retry': u'count=5 delay=1',
                                                       u'type': u'direct',
                                                       u'version': u'2.0'},
                                     u'set_deployment_failed': {u'name': u'set_deployment_failed',
                                                                u'on-success': u'send_message',
                                                                u'publish': {u'message': u'<% task(deploy).result %>',
                                                                             u'status': u'FAILED'},
                                                                u'type': u'direct',
                                                                u'version': u'2.0'},
                                     u'test_validations_enabled': {u'action': u'tripleo.validations.enabled',
                                                                   u'name': u'test_validations_enabled',
                                                                   u'on-error': u'send_message',
                                                                   u'on-success': u'copy_validation_ssh_keys',
                                                                   u'type': u'direct',
                                                                   u'version': u'2.0'}},
                          u'version': u'2.0'}},
 u'message': u"Failed to run action [action_ex_id=59ad9ba9-31de-4b10-9522-7076adeed1d1, action_cls='<class 'mistral.actions.action_factory.DeployStackAction'>', attributes='{}', params='{u'container': u'overcloud', u'timeout': 90}']\n ERROR: Failed to validate: Failed to validate: resources[0]: The Resource Type (OS::TripleO::SwiftStorage::Ports::ManagementPort) could not be found.",
 u'status': u'FAILED'}

Version-Release number of selected component (if applicable):
openstack-neutron-openvswitch-9.0.0-0.20160929051647.71f2d2b.el7ost.noarch
openstack-mistral-executor-3.0.0-0.20160929083341.c0a4501.el7ost.noarch
openstack-swift-container-2.10.1-0.20160929005314.3349016.el7ost.noarch
puppet-openstack_extras-9.4.0-1.el7ost.noarch
openstack-nova-common-14.0.0-1.el7ost.noarch
python-openstacksdk-0.9.5-0.20160912180601.d7ee3ad.el7ost.noarch
openstack-ironic-conductor-6.2.1-0.20160930163405.3f54fec.el7ost.noarch
openstack-nova-api-14.0.0-1.el7ost.noarch
openstack-heat-templates-0.0.1-0.20160920204709.f123aa1.el7ost.noarch
openstack-tripleo-image-elements-5.0.0-1.el7ost.noarch
python-openstack-mistral-3.0.0-0.20160929083341.c0a4501.el7ost.noarch
openstack-zaqar-3.0.0-1.el7ost.noarch
openstack-ironic-api-6.2.1-0.20160930163405.3f54fec.el7ost.noarch
openstack-heat-api-cfn-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
openstack-keystone-10.0.0-1.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.1.el7ost.noarch
puppet-openstacklib-9.4.0-0.20160929212001.0e58c86.el7ost.noarch
openstack-selinux-0.7.10-1.el7ost.noarch
openstack-tempest-12.2.1-0.20160927091836.ef2befe.el7ost.noarch
openstack-mistral-common-3.0.0-0.20160929083341.c0a4501.el7ost.noarch
openstack-tripleo-0.0.8-0.2.4de13b3git.el7ost.noarch
openstack-glance-13.0.0-1.el7ost.noarch
openstack-neutron-common-9.0.0-0.20160929051647.71f2d2b.el7ost.noarch
openstack-mistral-engine-3.0.0-0.20160929083341.c0a4501.el7ost.noarch
python-openstackclient-3.2.0-2.el7ost.noarch
openstack-neutron-ml2-9.0.0-0.20160929051647.71f2d2b.el7ost.noarch
openstack-ironic-inspector-4.2.1-0.20160922151040.36900fb.el7ost.noarch
openstack-heat-engine-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
openstack-swift-object-2.10.1-0.20160929005314.3349016.el7ost.noarch
openstack-nova-compute-14.0.0-1.el7ost.noarch
openstack-ironic-common-6.2.1-0.20160930163405.3f54fec.el7ost.noarch
openstack-heat-common-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
openstack-tripleo-puppet-elements-5.0.0-0.20160929220627.200d011.el7ost.noarch
openstack-neutron-9.0.0-0.20160929051647.71f2d2b.el7ost.noarch
openstack-nova-cert-14.0.0-1.el7ost.noarch
openstack-mistral-api-3.0.0-0.20160929083341.c0a4501.el7ost.noarch
openstack-heat-api-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
openstack-nova-scheduler-14.0.0-1.el7ost.noarch
openstack-swift-account-2.10.1-0.20160929005314.3349016.el7ost.noarch
openstack-puppet-modules-9.0.0-0.20160915155755.8c758d6.el7ost.noarch
openstack-tripleo-common-5.2.1-0.20160930181658.40ad7e5.el7ost.noarch
openstack-nova-conductor-14.0.0-1.el7ost.noarch
openstack-swift-proxy-2.10.1-0.20160929005314.3349016.el7ost.noarch
openstack-tripleo-ui-1.0.3-1.el7ost.noarch


How reproducible:
always

Steps to Reproduce:
1. deploy overcloud with the command above
2.
3.

Actual results:
see failure log above

Expected results:
deployment completes successfully

Additional info:

[stack@instack ~]$ cat network-environment.yaml 
resource_registry:
  OS::TripleO::BlockStorage::Net::SoftwareConfig: /home/stack/nic-configs/cinder-storage.yaml
  OS::TripleO::Compute::Net::SoftwareConfig: /home/stack/nic-configs/compute.yaml
  OS::TripleO::Controller::Net::SoftwareConfig: /home/stack/nic-configs/controller.yaml
  OS::TripleO::ObjectStorage::Net::SoftwareConfig: /home/stack/nic-configs/swift-storage.yaml
  OS::TripleO::CephStorage::Net::SoftwareConfig: /home/stack/nic-configs/ceph-storage.yaml


parameter_defaults:
  ExtraConfig:
    ceph::conf::args:
      global/osd_max_object_name_len:
        value: 256
      global/osd_max_object_namespace_len:
        value: 64
  NeutronExternalNetworkBridge: "''"
  InternalApiNetCidr: 192.168.100.0/24
  StorageNetCidr: 192.168.110.0/24
  StorageMgmtNetCidr: 192.168.120.0/24
  TenantNetCidr: 192.168.150.0/24
  ExternalNetCidr: 192.168.200.0/24
  InternalApiAllocationPools: [{'start': '192.168.100.10', 'end': '192.168.100.200'}]
  StorageAllocationPools: [{'start': '192.168.110.10', 'end': '192.168.110.200'}]
  StorageMgmtAllocationPools: [{'start': '192.168.120.10', 'end': '192.168.120.200'}]
  TenantAllocationPools: [{'start': '192.168.150.10', 'end': '192.168.150.200'}]
  # Use an External allocation pool which will leave room for floating IPs
  ExternalAllocationPools: [{'start': '192.168.200.180', 'end': '192.168.200.200'}]
  # Set to the router gateway on the external network
  ExternalInterfaceDefaultRoute: 192.168.200.1
  DnsServers: ["10.16.36.29"]
  ControlPlaneSubnetCidr: "24"
  ControlPlaneDefaultRoute: 192.0.2.1
  EC2MetadataIp: 192.0.2.1

Comment 1 Marius Cornea 2016-10-12 12:34:56 UTC
This is most probably related to https://bugs.launchpad.net/tripleo/+bug/1632663

Comment 2 Paul Grist 2016-10-12 21:33:14 UTC
Thanks Marius, I will track the progress of the upstream patch.

Comment 5 Alexander Chuzhoy 2016-10-26 19:11:54 UTC
Environment:
openstack-tripleo-heat-templates-5.0.0-0.20161008015357.0d3e3e3.1.el7ost.noarch


Reproduced:
 u'message': u"Failed to run action [action_ex_id=c660b9ef-204c-4b86-8db8-0e5ddf0ce31d, action_cls='<class 'mistral.actions.action_factory.DeployStackAction'>', attributes='{}', params='{u'container': u'overcloud', u'timeout': 240}']\n ERROR: Failed to validate: Failed to validate: resources[0]: The Resource Type (OS::TripleO::SwiftStorage::Ports::ManagementPort) could not be found.",

Comment 7 Christian Schwede (cschwede) 2016-11-03 15:55:03 UTC
Included in pkg openstack-tripleo-heat-templates-5.0.0-1.1.el7ost (or earlier).

Comment 11 errata-xmlrpc 2016-12-14 16:15:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html