Bug 138406

Summary: Loading ipw2200 firmware failed
Product: [Fedora] Fedora Reporter: Qantic <redhat>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: axel.thimm, fedora
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-02-03 13:30:36 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Qantic 2004-11-08 18:15:23 EST
Description of problem:

Same problem as in BUG #136011

Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200_boot.fw load failed
Unable to load firmware: 0xFFFFFFFE

of course firmwares are in /usr/lib/hotplug/firmware

Version-Release number of selected component (if applicable):

i'm using the latest udev-039-10.FC3.1
Comment 1 Warren Togami 2004-11-08 18:30:22 EST
Have you tried /lib/firmware?  That is the new standard location
chosen by the upstream hotplug project.
Comment 2 Qantic 2004-11-08 18:38:55 EST
it works with /lib/firmware thanks.
Comment 3 Otto 2004-11-23 20:12:01 EST
My wireless has stopped working after update (with up2date) in
November, 20, 2004.  I have "ipw2200_boot.fw load failed" at
/var/log/messages
I have firmwares at /lib/firmware, /etc/firmware/ and
/usr/lib/hotplug/firmware/
I have udev-039-10.FC3.2
Comment 4 Harald Hoyer 2004-11-24 04:15:42 EST
Otto: which kernel do you use?
Comment 5 Otto 2004-11-24 10:22:25 EST
At the moment of the problem the kernel was 2.6.9-1.667.
Yesterday I installed kernel 2.6.9-1.678_FC3 to see if the problem
happens on it.
Now I have 2 kernels in my machine and the problem occurs in both.
Comment 6 Harald Hoyer 2004-11-24 10:37:45 EST
could you try udev-039-10.FC3.2, which should also be available in the
updates?
Comment 7 Otto 2004-11-24 12:54:31 EST
I'm using it (see Additional Comment #3 above)

$ rpm -q udev
udev-039-10.FC3.2
Comment 8 Harald Hoyer 2004-11-25 04:27:46 EST
doh...

could you try the version from the development tree?
http://download.fedora.redhat.com/pub/fedora/linux/core/development/
Comment 9 Otto 2004-11-25 15:44:27 EST
I made a upgrade to kernel-2.6.9-1.681_FC3 and the message
"ipw2200_boot.fw load failed" didn't appear anymore at
/var/log/messages, but the wireless didn't work and past +/- 2 hour
after boot I got the error messages below at /var/log/messages.
Then I made the suggested upgrade to udev-042-1 and got the same
results (no "ipw2200_boot.fw load failed" message, wireless not
working and error messages below past +/- 2 hours after boot)

ERROR MESSAGES:
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: Fatal error
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: Start IPW Error Log Dump:
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: ERROR_DINOSTATUS_ERROR
-1499879535 0x0001c2ac  0x00008af8  0x00000104  0x03806f3c  0x00000041
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: ERROR_DMA_STATUS
-1499879531 0x00027af0  0x00027c70  0x01540001  0x00000000  0x00000000
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: ERROR_DMA_STATUS
-1499879528 0x00028400  0x000287f0  0x00540001  0x00000000  0x00000001
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: ERROR_DMA_STATUS
-1499879524 0x00028000  0x000281e0  0x00540000  0x9c6a4200  0x00000002
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: ERROR_DMA_STATUS
-1499879520 0x00408000  0x00408000  0x30408200  0x00000082  0x00000003
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: Start IPW Event Log Dump:
Nov 25 11:00:35 n6320dl36 kernel: ipw2200: -1499880599  0x00000438      27
etc, etc,...
Comment 10 Otto 2004-11-29 15:17:35 EST
No more comments?
Comment 11 Thorsten Leemhuis 2004-12-08 10:38:09 EST
Hi guys!

Otto, the ipw2200 driver is not in fedora core ATM. Where did you get
it? BTW it works for me with this RPMS:

http://www.leemhuis.info/files/fedorarpms/REPO.lvn/3/wlan/RPMS/ipw2200-firmware-2.0-0.lvn.5.noarch.rpm
http://www.leemhuis.info/files/fedorarpms/REPO.lvn/3/wlan/RPMS/kernel-module-ipw2200-2.6.9-1.681_FC3-0.16-0.lvn.1.i686.rpm

HTH
Comment 12 Otto 2004-12-19 12:26:23 EST
I got it from:
ipw2200-0.17-16.rhfc3.at.i386.rpms: http://atrpms.net/dist/fc3/ipw2200/

ipw2200-firmware-2.1-4.at.noarch.rpms:
http://atrpms.net/dist/common/ipw2200-firmware/

kernel-module-ipw2200-2.6.9-1.681_FC3-0.17-16.rhfc3.at.i686.rpms:
http://atrpms.net/dist/fc3/ipw2200/
Comment 13 Thorsten Leemhuis 2004-12-19 12:36:35 EST
Hi Otto, thanks for the info.

If you hav Problems with atrpms packages then atrpms bugzilla might be
the right place:
http://bugzilla.atrpms.net/

The packages/driver you refer are newer then my last post AFAICS. Do
they still have the problem?

And to see if this is a fedora core issue: Please remove the atrpms
packages, install the current -715 kernel from updates-testing,
install the firmware from ipw2200.sf.net manually to /lib/firmware and
see if its a problem there also -- but I suspect it is cause it works
fine for me.
Comment 14 Qantic 2004-12-20 16:50:47 EST
Hi,

I confirm the driver and firmware from ipw2200.sf.net are working with
the fedora kernel 2.6.9-1.681_FC3.

You can also found a rpm and srpm with ipw2200-0.18 drivers and
ipw2200-fw-2.1 firmware at http://www.qantic.com/fedora, if that can
help you.

Comment 15 Daniel Hedblom 2005-01-20 12:11:10 EST
With the right firmware ipw2200 works just splendid in RHFC3 with the
2.6.10-1.741-FC3 kernel. The ipw2200 module is included in that
version of the kernel but the firmware is not. The message
ipw2200_boot.fw load failed is displayed when the wrong version of
firmware is used or you dont have any firmware installed in
/lib/firmware, maybe other errors report this to i dont know. The
firmware i used with the kernel above is: v0.6-v0.16. Can anyone
confirm this?
Comment 16 George 2005-02-03 07:11:07 EST
I think I know what the issue is. I am using 2.6.10-1.760_FC3 kernel
udev-039-10.FC3.6 and at ATRPMS packages I downloaded from the link on
the sourceforge page:

ipw2200-firmware-2.2-5.at
ipw2200-1.0.0-23.rhfc3.at
ipw2200-kmdl-2.6.10-1.741_FC3-1.0.0-23.rhfc3.at

When you look at the error message it is about ipw2200_boot.fw,
however, the firmware in /lib/firmware is called ipw_2.2_boot.fw. I
symlinked the boot, bss and ucode and it worked (evidence is this
message:)

George
Comment 17 Thorsten Leemhuis 2005-02-03 11:35:57 EST
Still wondering why this bug is still open and not closed as NOTABUG

These *.at are all atrpms packages. If you have trouble -- go report at
http://bugzilla.atrpms.net/

Fedora does not/can't ship the firmware files due to the license. If
you  install them correctly then is works (at least for me, some other
people I know, and for you also it seems). So everything works from
the fedora-standpoint AFAICS.
Comment 18 Harald Hoyer 2005-02-03 13:30:36 EST
just trying to be nice and help :)  
Comment 19 Axel Thimm 2005-02-05 05:15:33 EST
George, in comment #16 you explicitely mention using kernel
2.6.10-1.760_FC3, but kmdls for 2.6.10-1.741_FC3. So you have been
using the kernel's ipw2200 (which is <= 0.16) instead of 1.0.0.

You need to get the kmdls matching your kernel. Use

<favourite tool here> install ipw2200-kmdl-`uname -r`

where favourite tool is yum/up2date/apt/smart.

(P.S. I just found this bug by searching for atrpms in comments
otherwise I would have commented earlier)
Comment 20 Gerald Hewes 2005-02-06 17:18:50 EST
I had the same comments as the person above. Could not get it worked 
util I changed the name of the firmware file in 
/lib/firmware

-rw-r--r--  2 root root   6472 Feb  6 16:22 ipw2200_boot.fw
-rw-r--r--  2 root root 166960 Feb  6 16:22 ipw2200_bss.fw
-rw-r--r--  2 root root 161568 Feb  6 16:22 ipw2200_ibss.fw
-rw-r--r--  2 root root  16312 Feb  6 16:22 ipw2200_ibss_ucode.fw
-rw-r--r--  2 root root  16334 Feb  6 16:22 ipw2200_ucode.fw
-rw-r--r--  2 root root   6472 Feb  6 16:22 ipw-2.2-boot.fw
-rw-r--r--  2 root root 166960 Feb  6 16:22 ipw-2.2-bss.fw
-rw-r--r--  2 root root  16334 Feb  6 16:22 ipw-2.2-bss_ucode.fw
-rw-r--r--  2 root root 161568 Feb  6 16:22 ipw-2.2-ibss.fw
-rw-r--r--  2 root root  16312 Feb  6 16:22 ipw-2.2-ibss_ucode.fw
Comment 21 Axel Thimm 2005-02-06 18:14:17 EST
rmmod ipw2200 and try

modprobe -ns ipw2200

to see which ipw2200 module is being loaded. It is probably not the
one from the packages you installed (they have /updates/ in their
paths, while the kernel's has /kernel/).

In that case you either have the wrong package for your kernel or a
module-init-tools that does not honor the updates folder.