Bug 1385304

Summary: Missing ODL ML2 Authentication info
Product: Red Hat OpenStack Reporter: Nir Yechiel <nyechiel>
Component: puppet-tripleoAssignee: Tim Rozet <trozet>
Status: CLOSED ERRATA QA Contact: Itzik Brown <itbrown>
Severity: unspecified Docs Contact:
Priority: high    
Version: 10.0 (Newton)CC: jjoyce, jschluet, mburns, rhel-osp-director-maint, slinaber, tvignaud
Target Milestone: rcKeywords: Triaged
Target Release: 10.0 (Newton)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: puppet-tripleo-5.3.0-4.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
N/A
Last Closed: 2016-12-14 16:20:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1258832    

Description Nir Yechiel 2016-10-16 05:56:59 UTC
Description of problem:

Without this, neutron-server fails to start and communication will not work to ODL REST.

Comment 1 Nir Yechiel 2016-10-16 05:58:51 UTC
Under review upstream. Will need to be cherry picked to stable/newton

Comment 2 Nir Yechiel 2016-10-21 12:37:44 UTC
Merged and cherry picked to branch stable/newton

Comment 3 Itzik Brown 2016-11-08 06:54:01 UTC
Checked with puppet-tripleo-5.3.0-4.el7ost.noarch.

username and password are present in /etc/neutron/plugins/ml2/ml2_conf.ini

Comment 7 errata-xmlrpc 2016-12-14 16:20:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html