Bug 1388640

Summary: ipa-server-install crashes in current Rawhide with "Installation failed: server failed to restart"
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: freeipaAssignee: IPA Maintainers <ipa-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: abokovoy, ipa-maint, jcholast, jhrozek, mkosek, pvoborni, rcritten, robatino, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-29 05:12:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1349184    

Description Adam Williamson 2016-10-25 19:40:44 UTC
The openQA FreeIPA server deployment test failed on today's Fedora Rawhide nightly compose:

https://openqa.fedoraproject.org/tests/44113

in ipaserver-install.log , we see this:

Installing CA into /var/lib/pki/pki-tomcat.
Storing deployment configuration into /etc/sysconfig/pki/tomcat/pki-tomcat/ca/deployment.cfg.

Installation failed: server failed to restart


2016-10-25T13:57:11Z DEBUG stderr=pkispawn    : ERROR    ....... server failed to restart

2016-10-25T13:57:11Z CRITICAL Failed to configure CA instance: Command '/usr/sbin/pkispawn -s CA -f /tmp/tmpCcwOCF' returned non-zero exit status 1
2016-10-25T13:57:11Z CRITICAL See the installation logs and the following files/directories for more information:
2016-10-25T13:57:11Z CRITICAL   /var/log/pki/pki-tomcat

followed by some tracebacks. I'll attach relevant log files directly, you can also download the entire /var/log of the test system at https://openqa.fedoraproject.org/tests/44113/file/role_deploy_domain_controller-var_log.tar.gz . (The install attempt also somehow triggered a kernel WARNING oops, note).

Proposing as a Fedora 26 Alpha blocker, per Alpha criterion "The core functional requirements for all Featured Server Roles must be met, but it is acceptable if moderate workarounds are necessary to achieve this" - 'domain controller' is one of the Featured roles, and this is part of its 'core functional requirements', obviously.

Comment 1 Alexander Bokovoy 2016-10-25 19:43:10 UTC
This should be solved with tomcat 8.0.38 update. See https://bz.apache.org/bugzilla/show_bug.cgi?id=60101 for details.

Comment 2 Adam Williamson 2016-10-25 19:52:06 UTC
confirmed that 60101 matches the logs, so I won't bother attaching them all. This should go away tomorrow.

Comment 3 Adam Williamson 2016-10-29 05:12:38 UTC
Well, this did go away, but deployment is still failing, apparently because it's somehow causing a GPF now...new bug report coming.

Comment 4 Adam Williamson 2016-10-29 05:19:26 UTC
New bug: https://bugzilla.redhat.com/show_bug.cgi?id=1389866 .