Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 138960 (IT_54131)

Summary: CRM #370922: Problem w/ XmStringCreateLocalized() and UTF-8 encoding string
Product: Red Hat Enterprise Linux 3 Reporter: James Antill <james.antill>
Component: openmotifAssignee: Thomas Woerner <twoerner>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: hp, tao
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-03-13 16:33:56 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
test code none

Description James Antill 2004-11-12 00:25:37 EST
Client is having a problem w/ XmStringCreateLocalized( char *text )
being unable to display UTF-8 encoding string.
----------
Action by: jantill
 This should really be compiled as...

g++ -Wall -W -o main main.cpp -L/usr/X11R6/lib -lXp -lXm -lXpm -lXt
-lXext -lX11

...but it still fails.
 I can't see anything wrong with the code.
Comment 1 James Antill 2004-11-12 00:27:30 EST
Created attachment 106553 [details]
test code
Comment 2 Havoc Pennington 2004-11-18 15:14:02 EST
*** Bug 138954 has been marked as a duplicate of this bug. ***
Comment 3 Owen Taylor 2004-11-18 15:32:23 EST
There are some relevant comments from me in bug 138954.
Comment 5 Marty Wesley 2004-12-01 10:03:19 EST

*** This bug has been marked as a duplicate of 139265 ***
Comment 10 Thomas Woerner 2004-12-07 10:03:01 EST
The problem is that OpenMotif has no UTF-8 support. Please have a look at:

http://www.openmotif.org/index.php?module=pagemaster&PAGE_user_op=view_page&PAGE_id=29&MMN_position=40:3
and
http://www.motifzone.net/forum/viewtopic.php?t=3097

OpenMotif-2.3 will have UTF-8 support, but there is no development
schedule or release date, yet.

The next OpenMotif versions (2.2.4 and 2.2.5) are bugfix releases and
will have no UTF-8 support. 


For japanese text, please try ja_JP.eucJP. This might work.
Comment 11 Havoc Pennington 2004-12-07 20:32:01 EST
eucJP doesn't work; the customer's program always leads openmotif to
call XDrawString() rather than XmbDrawString() regardless of locale
encoding.