Bug 1391250

Summary: Backport: "ceph osd df does not show summarized info correctly if one or more OSDs are out" : http://tracker.ceph.com/issues/16706
Product: Red Hat Ceph Storage Reporter: Vikhyat Umrao <vumrao>
Component: RADOSAssignee: Samuel Just <sjust>
Status: CLOSED ERRATA QA Contact: shylesh <shmohan>
Severity: medium Docs Contact: Bara Ancincova <bancinco>
Priority: medium    
Version: 1.3.3CC: ceph-eng-bugs, ceph-qe-bugs, dzafman, hnallurv, kchai, kdreyer, sjust
Target Milestone: rc   
Target Release: 2.2   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: RHEL: ceph-10.2.5-7.el7cp Ubuntu: ceph_10.2.5-3redhat1xenial Doc Type: Bug Fix
Doc Text:
.The "ceph df" output no longer includes OSD nodes marked as "out" The `ceph df` command shows cluster free space. Previously, the OSD node that were marked as `out` were incorrectly included in the output of `ceph df`. Consequently, if the Ceph cluster included an OSD node that was marked as `out`, the output of `ceph df` was incorrect. This bug has been fixed, and `ceph df` now correctly reports cluster free space.
Story Points: ---
Clone Of: 1391247 Environment:
Last Closed: 2017-03-14 15:46:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1391247    
Bug Blocks: 1412948    

Comment 1 Vikhyat Umrao 2016-11-02 20:55:37 UTC
jewel Backport tracker: http://tracker.ceph.com/issues/16866
jewel Backport PR: https://github.com/ceph/ceph/pull/10759

Comment 2 Ken Dreyer (Red Hat) 2017-01-17 03:14:30 UTC
Fixed upstream in v10.2.4

Comment 8 errata-xmlrpc 2017-03-14 15:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html