Bug 1391992

Summary: Unify flavor/image keys/properties
Product: Red Hat OpenStack Reporter: Marko Myllynen <myllynen>
Component: documentationAssignee: RHOS Documentation Team <rhos-docs>
Status: CLOSED EOL QA Contact: RHOS Documentation Team <rhos-docs>
Severity: low Docs Contact: Don Domingo <ddomingo>
Priority: low    
Version: 9.0 (Mitaka)CC: dcadzow, lmarsh, markmc, mburns, myllynen, nlevinki, scohen, srevivo
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-07-06 11:04:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Marko Myllynen 2016-11-04 14:39:04 UTC
Description of problem:
For example the following image properties that can be set:

hw_qemu_guest_agent
hw_vif_model
hw_vif_multiqueue_enabled
hw_watchdog_action

But only the following corresponding flavor key has effect:

hw:watchdog_action

It's unclear is there any reason for this distinction.

It would be nice of this distinction could be either documented properly (e.g., mention whether a key or a property can be used only with images or flavors or with both) or implement support for the currently unrecognised flavor keys which already are working as image properties.

There are also some properties which do not follow the above naming convention, like os_require_quiesce (but see bug 1385748), it would be nice to be able to set these as well on flavor basis.

Thanks.