Bug 1392921

Summary: [RFE] Automatically set SwiftMountCheck to true where it makes sense
Product: Red Hat OpenStack Reporter: David Juran <djuran>
Component: openstack-tripleo-heat-templatesAssignee: Christian Schwede (cschwede) <cschwede>
Status: CLOSED ERRATA QA Contact: Mike Abrams <mabrams>
Severity: medium Docs Contact: Don Domingo <ddomingo>
Priority: medium    
Version: 11.0 (Ocata)CC: cschwede, ddomingo, egafford, jomurphy, mabrams, mburns, nlevinki, rhel-osp-director-maint, scohen, tvignaud
Target Milestone: Upstream M3Keywords: FutureFeature, Triaged
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170130212245.el7ost Doc Type: Enhancement
Doc Text:
Feature: The mount_check option is now automatically enabled in Swift storage servers if the director setting SwiftRawDisks is used. SwiftRawDisks allows using additional disks on storage servers for Swift, and the mount_check option ensures improved failure handling. Reason: Result:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 19:38:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Juran 2016-11-08 13:41:35 UTC
Description of problem:
If Swift is backed by a raw disk, as opposed to a directory, the mount_check option in the DEFAULT section of /etc/swift/{account,container,object}-server.conf should be set to true, or bad things will happen[*]

The mount_check swift option is set using the SwiftMountCheck parameter in the heat templates. I suggest we, based on the value of the SwiftRawDisks (see bug 1368218 for details), set a reasonable default for the SwiftMountCheck parameter


Additional info:
[*] 
If one is using a raw disk for backing swift, and the SwiftMountCheck is set to false, if there is a disk failure on one of the nodes, creating containers will occasionally return an error code (503) to the end user. To further complicate things, even though 503 is returned, the container will still be created, even though the error was returned.

Comment 7 Thierry Vignaud 2017-02-14 17:16:15 UTC
Change is present in openstack-tripleo-heat-templates-6.0.0-0.20170130212245.el7ost (but it was already in tripleo-heat-templates-6.0.0.0b3.dev317)

Comment 12 errata-xmlrpc 2017-05-17 19:38:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245