Bug 139297

Summary: Audio CD plays only for root user
Product: [Fedora] Fedora Reporter: John Deal <johndeal>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: davidz, wgraham
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-16 09:57:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Deal 2004-11-14 19:29:17 EST
Description of problem: Will recognize and play auio cd in root, but
not in user


Version-Release number of selected component (if applicable):


How reproducible:  Insert CD and attempt to play

Steps to Reproduce:
1. Insert CD
2.
3.
  
Actual results: Gnome CD player reports "drive error" and Nautilu
reports "cdda:///dev/hcd is not a valid location"


Expected results: CD plays

Additional info: Works fine when I try it as root
Comment 1 David Zeuthen 2004-11-15 14:30:14 EST
This sounds like an udev bug - you might want to try to update your
system to the latest udev available. Reassigning to udev.
Comment 2 Harald Hoyer 2004-11-16 09:48:22 EST
update to the new udev update release...
See http://fedora.redhat.com/docs/udev/
Comment 3 John Deal 2004-11-16 17:51:08 EST
I ran up2date and now I'm playing a CD.  Ah, Beethoven.  Thanks.
Comment 4 Bill Graham 2004-11-21 20:41:31 EST
I have the same problem on my IBM T41 Laptop.  Tried both update
versions of udev - udev-039-10.FC3.1 and udev-039-10.fc3.2.  Will play
as root will not play under my username. Thank you.
Comment 5 Harald Hoyer 2004-11-22 05:57:58 EST
Bill Graham: could you please run:
$ ls -l /dev/cdrom 
???
Comment 6 Bill Graham 2004-11-22 12:36:05 EST
Sure, the response was:
lrwxrwxrwx  1 root root 3 Nov 22 07:28 /dev/cdrom -> hdc
Thanks for your help.
Comment 7 Bill Graham 2004-11-22 12:42:13 EST
My fault, I did not see the link in /dev to cdrom.  I was pointing the
CD player to /media/cdrecorder. It is now working.  Thank you.