Bug 1395723

Summary: Links to Subscriptions from activation key are broken
Product: Red Hat Satellite Reporter: Martin Bacovsky <mbacovsk>
Component: Activation KeysAssignee: Brad Buckingham <bbuckingham>
Status: CLOSED ERRATA QA Contact: jcallaha
Severity: low Docs Contact:
Priority: medium    
Version: 6.2.4CC: bbuckingham, jcallaha
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-21 16:54:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
verification screenshot none

Description Martin Bacovsky 2016-11-16 14:18:49 UTC
Description of problem:
hyperlink of the susbcription from the activation keys -> subscriptions page doesn't work. It appears to be missing an id in the URL that need sot be present.

Version-Release number of selected component (if applicable):
# rpm -q satellite
satellite-6.2.4-1.0.el7sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 6.2.4
2. Go to https://satellite/activation_keys/XXX/add-subscriptions
     (replace XXX with a valid activation key ID)
3. Attempt to click on the title of one of the Subscriptions (see screenshot for where to click)

Actual results:
You'll observe that the subscription name hyperlinks to "https://satellite/subscriptions//info" (note the double-/ character - between the should be a subscription ID).

Expected results:
Hyperlinks contain subscription ids

Additional info:

Comment 2 Martin Bacovsky 2016-11-16 14:27:59 UTC
Created redmine issue http://projects.theforeman.org/issues/17363 from this bug

Comment 4 Brad Buckingham 2016-11-21 16:54:37 UTC
Fix proposed in Katello PR: https://github.com/Katello/katello/pull/6466

Comment 5 jcallaha 2017-08-10 18:37:02 UTC
Verified in Satellite 6.3. Snap 10.

The subscriptions are now linked appropriately. See attached image for verification.

Comment 6 jcallaha 2017-08-10 18:37:18 UTC
Created attachment 1311858 [details]
verification screenshot

Comment 8 Satellite Program 2018-02-21 16:54:37 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.
> > 
> > For information on the advisory, and where to find the updated files, follow the link below.
> > 
> > If the solution does not work for you, open a new bug report.
> > 
> > https://access.redhat.com/errata/RHSA-2018:0336