Bug 1397764

Summary: unable to add a puppet module from satellite GUI
Product: Red Hat Satellite Reporter: Giridhar <gkonda>
Component: Content ViewsAssignee: John Mitsch <jomitsch>
Status: CLOSED ERRATA QA Contact: Walden Raines <walden>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.2.4CC: bbuckingham, jcallaha, jomitsch, ohadlevy, walden
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-21 16:51:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Giridhar 2016-11-23 10:23:14 UTC
Description of problem:
Unable to add a puppet module to content view from satellite GUI when there are so many puppet modules with more than one version of the same module

Version-Release number of selected component (if applicable):
6.2.4 and 3.8

How reproducible:
Always

Steps to Reproduce:
1.sync the puppet forge
2.add 10 to 15 versions of same module for some modules
3.create a content view and try adding a puppet module(In my case the cu was trying to add razoredges network module)
4.initially the module would appear and while selecting the version it would again take you back to the modules that have the search content in their summary.
5.if there are somany modules in the repo then we will not find the complete list in the page and there is no option to go to the second page.
6.as the required module isn't available we are not able to add it.

Actual results:

the required module isn't available

Expected results:

we should be able to select the next page and select the required module

Additional info:

Comment 1 Brad Buckingham 2017-01-05 01:07:39 UTC
Created redmine issue http://projects.theforeman.org/issues/17930 from this bug

Comment 3 Satellite Program 2017-03-03 17:08:07 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/17930 has been resolved.

Comment 4 Walden Raines 2017-08-02 18:15:59 UTC
Verified in 6.3.0 snap 9, I can now select any module version on any page.

Comment 6 Satellite Program 2018-02-21 16:51:07 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.
> 
> For information on the advisory, and where to find the updated files, follow the link below.
> 
> If the solution does not work for you, open a new bug report.
> 
> https://access.redhat.com/errata/RHSA-2018:0336