Bug 1398030

Summary: colord trying to access hwdata
Product: Red Hat Enterprise Linux 7 Reporter: Phil Wyett <philwyett.hemisphere>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED DUPLICATE QA Contact: Milos Malik <mmalik>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: lvrabec, mgrepl, mmalik, plautrba, pvrabec, ssekidde
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-24 11:21:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Phil Wyett 2016-11-23 22:40:04 UTC
Description of problem:

SELinux is preventing /usr/libexec/colord from read access on the file /etc/udev/hwdb.bin.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that colord should be allowed read access on the hwdb.bin file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'colord' --raw | audit2allow -M my-colord
# semodule -i my-colord.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0
Target Context                system_u:object_r:systemd_hwdb_etc_t:s0
Target Objects                /etc/udev/hwdb.bin [ file ]
Source                        colord
Source Path                   /usr/libexec/colord
Port                          <Unknown>
Host                          hemi-yoda
Source RPM Packages           colord-1.2.7-2.el7.x86_64
Target RPM Packages           systemd-219-30.el7.x86_64
Policy RPM                    selinux-policy-3.13.1-102.el7.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     hemi-yoda
Platform                      Linux hemi-yoda 3.10.0-514.el7.x86_64 #1 SMP Tue
                              Nov 22 16:42:41 UTC 2016 x86_64 x86_64
Alert Count                   5
First Seen                    2016-11-23 21:40:14 GMT
Last Seen                     2016-11-23 22:16:51 GMT
Local ID                      79ebf87c-539c-49d3-aad7-33dddf992ef5

Raw Audit Messages
type=AVC msg=audit(1479939411.884:169): avc:  denied  { read } for  pid=2010 comm="colord" name="hwdb.bin" dev="sda3" ino=1252741 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:object_r:systemd_hwdb_etc_t:s0 tclass=file


type=SYSCALL msg=audit(1479939411.884:169): arch=x86_64 syscall=open success=no exit=EACCES a0=7f63c28472fb a1=80000 a2=1b6 a3=24 items=1 ppid=1 pid=2010 auid=4294967295 uid=995 gid=993 euid=995 suid=995 fsuid=995 egid=993 sgid=993 fsgid=993 tty=(none) ses=4294967295 comm=colord exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0 key=(null)

type=CWD msg=audit(1479939411.884:169): cwd=/

type=PATH msg=audit(1479939411.884:169): item=0 name=/etc/udev/hwdb.bin inode=1252741 dev=08:03 mode=0100444 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:systemd_hwdb_etc_t:s0 objtype=NORMAL

Hash: colord,colord_t,systemd_hwdb_etc_t,file,read


Actual results:

A warning.

Expected results:

No warning.


Additional info:

Comment 1 Milos Malik 2016-11-24 08:05:49 UTC
I believe this bug is a duplicate of BZ#1373082.

Comment 2 Lukas Vrabec 2016-11-24 11:21:18 UTC

*** This bug has been marked as a duplicate of bug 1373082 ***