Bug 1402489

Summary: Disable CONFIG_KCM on all fedora kernels
Product: [Fedora] Fedora Reporter: Hannes Frederic Sowa <hsowa>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: cz172638, gansalmon, hsowa, ichavero, itamar, jonathan, kernel-maint, labbott, madhu.chinakonda, mchehab
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: kernel-4.8.13-300.fc25 kernel-4.8.13-200.fc24 kernel-4.8.13-100.fc23 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-13 00:00:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Hannes Frederic Sowa 2016-12-07 16:23:00 UTC
KCM and strparser hasn't been reviewed extensively during their upstreaming phase and were accepted despite criticism of the architecture.

Doing socket(AF_KCM) autoloads the module and exposes it for ordinary users. Please blacklist this module from autoloading or (even better) remove it from the kernel config completely.

Comment 1 Laura Abbott 2016-12-07 17:59:59 UTC
The option had been turned on when it came in because it was available as a module. There was no strong use case so I turned it off on all branches. It will be staying off until we hear that the architecture problems have been addressed.

Comment 2 Fedora Update System 2016-12-09 22:51:12 UTC
kernel-4.8.13-300.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-107f03cc00

Comment 3 Fedora Update System 2016-12-09 22:52:31 UTC
kernel-4.8.13-200.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5cb5b4082d

Comment 4 Fedora Update System 2016-12-09 22:53:00 UTC
kernel-4.8.13-100.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5aff4a6bbc

Comment 5 Fedora Update System 2016-12-11 03:29:44 UTC
kernel-4.8.13-300.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-107f03cc00

Comment 6 Fedora Update System 2016-12-11 03:57:59 UTC
kernel-4.8.13-200.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5cb5b4082d

Comment 7 Fedora Update System 2016-12-11 03:59:47 UTC
kernel-4.8.13-100.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5aff4a6bbc

Comment 8 Fedora Update System 2016-12-13 00:00:17 UTC
kernel-4.8.13-300.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-12-13 02:26:47 UTC
kernel-4.8.13-200.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-12-13 04:21:48 UTC
kernel-4.8.13-100.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.