Bug 1402897

Summary: python-os-brick package contains unit tests
Product: Red Hat OpenStack Reporter: Eric Harney <eharney>
Component: python-os-brickAssignee: Eric Harney <eharney>
Status: CLOSED ERRATA QA Contact: Tzach Shefi <tshefi>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 10.0 (Newton)CC: achernet, apevec, jschluet, lhh, lkuchlan
Target Milestone: Upstream M3   
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-os-brick-1.10.0-0.20170120195057.1a9b90b.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 19:50:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Eric Harney 2016-12-08 14:53:30 UTC
python-os-brick contains unit tests in /usr/lib/python2.7/site-packages/os_brick/tests .

These should not be installed as part of the main python-os-brick package.

Comment 4 lkuchlan 2017-04-09 05:48:14 UTC
Tested using:
python-os-brick-1.11.0-1.el7ost.noarch

The unit test files are not in the RPM.

Comment 5 errata-xmlrpc 2017-05-17 19:50:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245