Bug 1404251

Summary: build of systemd sometimes fails
Product: Red Hat Enterprise Linux 7 Reporter: Lukáš Nykrýn <lnykryn>
Component: systemdAssignee: systemd-maint
Status: CLOSED ERRATA QA Contact: Branislav Blaškovič <bblaskov>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.4CC: bblaskov, fsumsal, systemd-maint-list
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: systemd-219-31.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-01 09:12:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Lukáš Nykrýn 2016-12-13 13:24:08 UTC
Description of problem:
Occasionally build fails with:

src/udev/mtd_probe/mtd_probe.h:26:9: error: unknown type name 'uint32_t'
         uint32_t reserved;
         ^

Comment 1 Lukáš Nykrýn 2016-12-13 13:27:49 UTC
https://github.com/lnykryn/systemd-rhel/pull/71

Comment 2 Lukáš Nykrýn 2016-12-13 13:40:31 UTC
fix merged to upstream staging branch ->
https://github.com/lnykryn/systemd-rhel/commit/5c1473ccbbcdf4f1ec3b18609adb351946ed74b5
-> post

Comment 5 errata-xmlrpc 2017-08-01 09:12:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2297