Bug 1404444

Summary: [SPEC] /usr/lib/systemd/system/dbus-org.freedesktop.network1.service: broken symbolic link to `systemd-networkd.service'
Product: Red Hat Enterprise Linux 7 Reporter: John Dodson <jwadodson>
Component: systemdAssignee: systemd-maint
Status: CLOSED ERRATA QA Contact: Radka Brychtova <rskvaril>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.3CC: fsumsal, jay.hilliard, jsynacek, mmontefl, msugaya, psklenar, rskvaril, syamamot, systemd-maint-list
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: systemd-219-32.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-01 09:12:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1383699    

Description John Dodson 2016-12-13 21:29:55 UTC
Description of problem:

/usr/lib/systemd/system/dbus-org.freedesktop.network1.service: broken symbolic link to `systemd-networkd.service'
There should be no broken symlinks.

Version-Release number of selected component (if applicable):


How reproducible:

always (recently)

Steps to Reproduce:
1. ls -l /usr/lib/systemd/system/dbus-org.freedesktop.network1.service
2. file /usr/lib/systemd/system/dbus-org.freedesktop.network1.service

Actual results:
/usr/lib/systemd/system/dbus-org.freedesktop.network1.service: broken symbolic link to `systemd-networkd.service'

Expected results:

There should be no broken symlinks

Additional info:

Comment 1 Jan Synacek 2016-12-14 07:53:21 UTC
Yep, we only ship the socket file.

Comment 2 John Dodson 2016-12-15 05:31:18 UTC
I don't understand that comment.

Who is "we", & which "socket" file & what does that have to do with the broken symlink?

Maybe I should also point out (sorry I should have included it originally)...

rpm -q --whatprovides /usr/lib/systemd/system/dbus-org.freedesktop.network1.service

which implies that systemd is to blame for creating a symlink to something that does not exist? (namely "./systemd-networkd.service" which would again implicate systemd (the package) in the problem.

If what you mean is "we only ship the symlink" then the symlink should not be
shipped if the target does not exist & the package that "needs" the symlink should only create it when it's actually needed & the target exists.

Comment 3 Lukáš Nykrýn 2016-12-15 06:58:36 UTC
In short, /usr/lib/systemd/system/dbus-org.freedesktop.network1.service should be in systemd-networkd subpackage not in systemd itself. We will fix that.

Comment 4 John Dodson 2016-12-15 10:57:18 UTC
Will it still be a broken symlink?
Or will the symlink & target be appropriately dealt with so the symlink is never broken

Comment 5 Lukáš Nykrýn 2017-02-20 12:49:40 UTC
*** Bug 1375882 has been marked as a duplicate of this bug. ***

Comment 9 John Dodson 2017-04-18 04:28:43 UTC
I note that this is still not fixed for us (systemd-219-30.el7_3.8.x86_64)

When will systemd-219-32.el7 get to us?

Comment 10 Lukáš Nykrýn 2017-04-18 08:32:39 UTC
(In reply to John Dodson from comment #9)
> I note that this is still not fixed for us (systemd-219-30.el7_3.8.x86_64)
> When will systemd-219-32.el7 get to us?

With rhel-7.4.

Comment 11 spirited 2017-05-01 14:29:21 UTC
I think I ran into this after installing package from RDO. Is there a workaround?

Comment 12 Lukáš Nykrýn 2017-05-03 11:04:49 UTC
you can try systemctl mask dbus-org.freedesktop.network1.service

Comment 13 errata-xmlrpc 2017-08-01 09:12:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.