Bug 1405391

Summary: cloud-init of Fedora Base Cloud Image 25 fails to reach servers
Product: [Fedora] Fedora Reporter: Victor Stinner <vstinner>
Component: cloud-initAssignee: Garrett Holmstrom <gholms>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: adimania, apevec, gholms, Jan.van.Eldik, shardy, s
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-16 14:41:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Victor Stinner 2016-12-16 11:25:48 UTC
I downloaded a cloud image of Fedora 25 from:
http://ftp.free.fr/mirrors/fedora.redhat.com/fedora/linux/releases/25/CloudImages/x86_64/images/Fedora-Cloud-Base-25-1.3.x86_64.qcow2

At boot, cloud-init fails to fetch my config and so I cannot connect to the VM through SSH: the VM doesn't listen to tcp/22!

I'm sorry, I didn't keep logs of the failing cloud-init. I only know that it tried to connect to http://169.254.169.254/2009-04-04/meta-data/instance-id but failed with a timeout. It tried other IPs like 192.168.0.1 if I recall correctly.

I don't know which login/password I am supposed to use, it's very hard to find any information about Fedora cloud images :-(

See also my complain about the lack of documentation, bug report on the website tracker:
https://fedorahosted.org/fedora-websites/ticket/415

I will now try a cloud image from another "random URL" (not mentionned on the main Fedora website, so should I trust it or not?):

https://kojipkgs.fedoraproject.org/compose/twoweek/Fedora-Atomic-25-20161216.0/compose/CloudImages/x86_64/images/Fedora-Cloud-Base-25-20161216.0.x86_64.qcow2

Comment 1 Victor Stinner 2016-12-16 14:41:04 UTC
Sorry, it seems like my (virtual) router was broken after a reboot of an OpenStack controller.

I suspected the new Fedora image before last week it worked fine, but in fact the router crashed during the weekend. Moreover, the router still replied to ping, the issue was more subtle than that...

I didn't know that the router can cause issues at cloud-init...