Bug 1405593

Summary: Can't print in color even though PPD says it is a color device
Product: [Fedora] Fedora Reporter: Robin A. Meade <robin.a.meade>
Component: cupsAssignee: Zdenek Dohnal <zdohnal>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: jpopelka, twaugh, zdohnal
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-17 02:29:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robin A. Meade 2016-12-16 19:21:10 UTC
I can't print in color even though the PPD file says it is a color device.

As suggested [1] in Xerox forums, I extracted the "generic" PPD file from the Windows driver download [2]. Also found here: http://pastebin.com/J9aJAA6x

[1] http://forum.support.xerox.com/t5/General-Information/can-t-install-workcentre-7830-printer-on-debian-linux-using/td-p/196202

[2] http://www.support.xerox.com/support/workcentre-7800-series/file-download/enus.html?operatingSystem=winxp&fileLanguage=en&&associatedProduct=WorkCentre-78xx-built-in%20controller&contentId=133581&from=downloads&viewArchived=false

The PPD file does in fact report that it is a color device, with these two lines:

*ColorDevice: True
*DefaultColorSpace: CMYK

However, the Color tab of the GTK Print Dialog says:

   Printer Profile: Unspecified Profile

I expected it to give me the option to print in color, like: 

   Color Mode: 
       [ ] Color
       [*] Greyscale

I tried adding a cupsICCProfile line to the PPD file:

*cupsICCProfile ../Default: "/usr/share/color/icc/colord/AdobeRGB1998.icc"

but it had no effect.

ADDITIONAL INFO: The printer is a Xerox WorkCentre 7855. Prior to Fedora 25, I was able to print in color by creating the queue using Xerox's printer driver for linux. When done in this way, printing to that queue launches the Xerox printer dialog with many option. But that no longer works because cups 2.2 removed support for System V Interface scripts.

Comment 1 Robin A. Meade 2016-12-17 02:29:02 UTC
Closing. Not a bug in Fedora.

I assume the Xerox's PPD file isn't declaring its color capabilities in a way that allows the GTK Print Dialog to offer the Color Mode options. I haven't been able to determine what that proper way is. Maybe EFColorMode ? But that's a problem for the printer manufacturer.

I've since downgraded my CUPS to 2.1.x (by using Fedora 24's RPMs) and thus can now use the Xerox Linux Printer Driver software downloaded from xerox.com to handle print jobs.