Bug 140597

Summary: [PATCH] "use vX.X.X" causes problems with perl.req
Product: [Fedora] Fedora Reporter: Steven Pritchard <steve>
Component: rpmAssignee: Paul Nasrat <nobody+pnasrat>
Status: CLOSED UPSTREAM QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: nobody+pnasrat, perl-devel, redhat-bugzilla, scop
Target Milestone: ---Keywords: EasyFix, Patch
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-02 19:09:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150222    
Attachments:
Description Flags
support "v<number>" version numbers in perl.req
none
support "v<number>" version numbers in perl.req
none
Patch against today's rawhide spec none

Description Steven Pritchard 2004-11-23 19:32:04 UTC
Description of problem:
/usr/lib/rpm/perl.req doesn't handle a line like this properly:

  use v5.6.0;

This is valid perl (at least since 5.6.0) and is easy to support with
the attached patch.

Version-Release number of selected component (if applicable):
4.3.2-21

Comment 1 Steven Pritchard 2004-11-23 19:34:41 UTC
Created attachment 107326 [details]
support "v<number>" version numbers in perl.req

Apply to /usr/lib/rpm/perl.req.

Comment 2 Steven Pritchard 2005-05-28 15:56:55 UTC
This bug is still present in rawhide.

Comment 3 Steven Pritchard 2005-05-28 16:41:52 UTC
Created attachment 114942 [details]
support "v<number>" version numbers in perl.req

Patch updated to rpm 4.4.1.

Comment 4 Steven Pritchard 2005-05-28 16:44:02 UTC
Created attachment 114943 [details]
Patch against today's rawhide spec

Comment 5 Seth Vidal 2005-05-28 16:57:28 UTC
Marking as EasyFix for submitter

Comment 6 Ville Skyttä 2005-06-15 16:22:57 UTC
Looks sane to me. 
 
BTW, stuff around the patch to rpm would benefit from updating for Perl 5.8 
(Epoch: 2 and/or 3, don't remember where it was bumped) as well as possibly 
converting underscores to dots (somehow?) in the emitted version. 

Comment 7 Jeff Johnson 2005-11-02 19:09:53 UTC
Checked into rpm CVS, should be in rpm-4.4.3-0.32 when built.