Bug 1406545

Summary: file upload in courses broken in 3.1.3
Product: [Fedora] Fedora EPEL Reporter: richlv <richlv>
Component: moodleAssignee: Gwyn Ciesla <gwync>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: epel7CC: gwync, sergio
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-04 09:41:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description richlv 2016-12-20 21:31:43 UTC
Description of problem:
uploading files to be attached to courses is not possible - file uploader never shows up, the spinner keeps on spinning.

Version-Release number of selected component (if applicable):
3.1.3

How reproducible:
attempt to upload a file, attached to a course. note that file uploading in other places works.

Steps to Reproduce:
1. go to a course
2. enable editing mode
3. open file uploading form

Actual results:
only the spinner is shown, file upload form is missing

Expected results:
file upload form to be shown

Additional info:

after a lot of attempts, eventually moodle was manually upgraded to 3.1.3+ (3.1.3 "with some bugfixes", according to the moodle webpage). it is not clear which exact fix helped, but file upload worked in that version.

Comment 1 Gwyn Ciesla 2016-12-21 15:25:28 UTC
Shipping the + versions can be problematic.  Can you try this 3.2 build?

https://fedorapeople.org/~limb/moodle/moodle-3.2-1.el7.centos.noarch.rpm

Comment 2 Fedora Update System 2017-01-09 18:28:44 UTC
moodle-3.2.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-80cfb13391

Comment 3 richlv 2017-01-10 01:54:31 UTC
thanks a lot for the upgrade - sorry for not coming back with the testing, did not find the time for that until now :/

Comment 4 Fedora Update System 2017-01-10 10:19:51 UTC
moodle-3.2.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-80cfb13391

Comment 5 Sergio Basto 2018-09-04 09:40:10 UTC
"but file upload worked in that version" , seems this bug is fixed , closing , please reopen it if not , thanks.