Bug 1406600

Summary: [RFE] Update configuration modules to support TCMU based LIO implementations
Product: Red Hat Ceph Storage Reporter: Paul Cuzner <pcuzner>
Component: DistributionAssignee: Jason Dillaman <jdillama>
Status: CLOSED ERRATA QA Contact: ceph-qe-bugs <ceph-qe-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 2.1CC: adeza, aschoen, ceph-eng-bugs, gmeno, hnallurv, icolle, jdillama, kdreyer, nthomas, sankarshan
Target Milestone: rcKeywords: FutureFeature
Target Release: 2.3   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ceph-iscsi-config-2.0-3.el7cp Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-06-19 13:28:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1445750    
Bug Blocks: 1406551    

Description Paul Cuzner 2016-12-21 01:04:24 UTC
Description of problem:
The current (1.5) release of ceph-iscsi-config supports rbd's provided through krbd/device-mapper. In order for the config modules to support rbd's through TCMU, some code refactoring will be necessary.

This RFE serves as a tracker for this update activity

Version-Release number of selected component (if applicable):
Goal for TCMU integration - RHCS 2.2


Additional info:
These modules are used by
- rbd-target-gw
- ceph-iscsi-ansible (ceph-ansible) playbooks
- ceph-iscsi-cli (gwcli command)

Comment 8 errata-xmlrpc 2017-06-19 13:28:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497