Bug 1409837

Summary: perl-Test-Smoke-1.70-3.fc26 FTBFS on aarch64: Argument "" isn't numeric in sprintf at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 232.
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perl-Test-SmokeAssignee: Jitka Plesnikova <jplesnik>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jplesnik, perl-devel
Target Milestone: ---   
Target Release: ---   
Hardware: aarch64   
OS: Unspecified   
URL: https://apps.fedoraproject.org/koschei/package/perl-Test-Smoke?collection=f26
Whiteboard:
Fixed In Version: perl-Test-Smoke-1.70-4.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-04 15:30:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Petr Pisar 2017-01-03 15:13:46 UTC
perl-Test-Smoke-1.70-3.fc26 fails to build in F26 because a test fails on aarch64 platform:

t/syncer_snap.t .................. ok
#   Failed test 'no warnings'
#   at /usr/share/perl5/vendor_perl/Test/Builder.pm line 135.
# There were 3 warning(s)
# 	Previous test 9 'buildvm-aarch64-06.arm.fedoraproject.org'
# 	Argument "" isn't numeric in sprintf at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 232.
#  at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 232.
# 	Test::Smoke::SysInfo::Linux::linux_generic(Test::Smoke::SysInfo::Linux=HASH(0x302d8b48)) called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 30
# 	Test::Smoke::SysInfo::Linux::prepare_sysinfo(Test::Smoke::SysInfo::Linux=HASH(0x302d8b48)) called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Base.pm line 35
# 	Test::Smoke::SysInfo::Base::new("Test::Smoke::SysInfo::Linux") called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo.pm line 71
# 	Test::Smoke::SysInfo::new("Test::Smoke::SysInfo") called at t/sysinfo.t line 33
# 
# ----------
# 	Previous test 15 'buildvm-aarch64-06.arm.fedoraproject.org'
# 	Argument "" isn't numeric in sprintf at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 232.
#  at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 232.
# 	Test::Smoke::SysInfo::Linux::linux_generic(Test::Smoke::SysInfo::Linux=HASH(0x2f84bd58)) called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 30
# 	Test::Smoke::SysInfo::Linux::prepare_sysinfo(Test::Smoke::SysInfo::Linux=HASH(0x2f84bd58)) called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Base.pm line 35
# 	Test::Smoke::SysInfo::Base::new("Test::Smoke::SysInfo::Linux") called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo.pm line 71
# 	Test::Smoke::SysInfo::new("Test::Smoke::SysInfo") called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo.pm line 86
# 	Test::Smoke::SysInfo::sysinfo() called at t/sysinfo.t line 48
# 
# ----------
# 	Previous test 17 'sysinfo: buildvm-aarch64-06.arm.fedoraproject.org linux - 4.8.8-200.fc24.aarch64 [Fedora 26 (Rawhide)] aarch64'
# 	Argument "" isn't numeric in sprintf at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 232.
#  at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 232.
# 	Test::Smoke::SysInfo::Linux::linux_generic(Test::Smoke::SysInfo::Linux=HASH(0x302d8b48)) called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Linux.pm line 30
# 	Test::Smoke::SysInfo::Linux::prepare_sysinfo(Test::Smoke::SysInfo::Linux=HASH(0x302d8b48)) called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo/Base.pm line 35
# 	Test::Smoke::SysInfo::Base::new("Test::Smoke::SysInfo::Linux") called at /builddir/build/BUILD/Test-Smoke-1.70/blib/lib/Test/Smoke/SysInfo.pm line 71
# 	Test::Smoke::SysInfo::new("Test::Smoke::SysInfo") called at t/sysinfo.t line 56
# 
# Looks like you failed 1 test of 57.
t/sysinfo.t ...................... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/57 subtests 

Koschei history shows it happens on aarch64 only.