Bug 1409872

Summary: [Intel OSP12] SNMP Write Plugin
Product: Red Hat OpenStack Reporter: damien Power <damien.power>
Component: collectdAssignee: Ryan McCabe <rmccabe>
Status: CLOSED ERRATA QA Contact: Leonid Natapov <lnatapov>
Severity: urgent Docs Contact:
Priority: high    
Version: 12.0 (Pike)CC: acanan, brault, damien.power, dcadzow, joflynn, lnatapov, mbracho, mmagr, mrunge, pkilambi, rmccabe, robert.h.armstrong, robert.w.love, sclewis, sgordon, sunku.ranganath, tony.b.mcmahon
Target Milestone: Upstream M1Keywords: FutureFeature, OtherQA, Triaged
Target Release: 16.1 (Train on RHEL 8.2)   
Hardware: Unspecified   
OS: Linux   
Whiteboard: docs-accepted
Fixed In Version: collectd-5.8.0-12.el7ost Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1409814 Environment:
Last Closed: 2020-07-29 07:49:26 UTC Type: Feature Request
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1458000, 1476902, 1573955    

Description damien Power 2017-01-03 16:51:57 UTC
+++ This bug was initially created as a clone of Bug #1409814 +++

1. Feature Overview:
a) Name of feature: SNMP Write Plugin 
b) Feature Description: 
Plugin will act as a SNMP subagent and will map collectd metrics to relavent OIDs. Will only support SNMP: get, getnext and walk.

2. Feature Details:
a) Architectures:
b) Bugzilla Dependencies:
c) Drivers or hardware dependencies: n/a
d) Upstream acceptance information: Spec and implementation in progress.

e) External links:

f) Severity (H,M,L): M
g) Feature Needed by:

3. Business Justification:
a) Why is this feature needed?
b) What hardware does this enable? n/a
c) Is this hardware on-board in a system (eg, LOM) or an add-on card? No
d) Business impact? n.a
e) Other business drivers:

4. Primary contact at Red Hat, email, phone (chat):

5. Primary contact at Partner, email, phone (chat):
Rob Love
robert.w.love

Comment 3 damien Power 2017-03-30 13:18:53 UTC
Collect PR https://github.com/collectd/collectd/pull/2105

Comment 4 Robert Love 2017-04-06 16:36:57 UTC
Not yet upstream, RH concerned about capacity for OSP12, so moving to target Queen release.

Comment 5 Matthias Runge 2017-05-19 06:39:42 UTC
This has been recently merged, but no new version was released.

Comment 6 Red Hat Bugzilla Rules Engine 2017-05-19 06:39:49 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 7 damien Power 2017-05-24 13:24:09 UTC
SNMP write plugin has been given "new plugin" label and been mergerd tp main collectd branch 
please review  https://github.com/collectd/collectd/pull/2105

the collectd Release is controlled by collectd community.
Latest release was Version 5.7 Jan 23rd 2017
https://collectd.org/wiki/index.php/Version_5.7

The next collectd release date is not known. It is assumed that this will be part of this as it is upstreamed. 

Can you review this comment and review the bump to Queens

Comment 8 Matthias Runge 2017-05-31 08:46:50 UTC
snmp write plugin was merged after the last release to collectd and thus is not included in collectd 5.7.x.

Comment 9 Matthias Runge 2017-09-12 09:53:47 UTC
Moving to osp13, merge window for pike is closed now. There wasn't a upstream release for a while now, and adding this to OSP requires it to be added to kolla images.

Comment 11 damien Power 2017-10-13 13:02:34 UTC
Merged to Master PR #2105, #2362
Available for next 5.8 Release

Comment 12 tony.b.mcmahon 2017-12-15 11:43:10 UTC
Available in collectd 5.8 release (released November 11th 2017)

Comment 17 sunku ranganath 2018-08-03 17:40:31 UTC
The Severity has been increased to "Urgent" due to customer request.

Comment 25 Bertrand 2020-02-25 14:44:48 UTC
Intel is expected to share their QA/test plan.

Comment 32 Matthias Runge 2020-06-03 08:51:43 UTC
The snmp agent also requires a running snmpd service. In addition to 

parameter_defaults:
    CollectdExtraPlugins:
        - snmp_agent

In order to deploy the snmp service, please add

resource_registry:
    OS::TripleO::Services::Snmp: /usr/share/openstack-tripleo-heat-templates/deployment/snmp/snmp-baremetal-puppet.yaml

to a to be written collectd-configuration.yaml

Comment 33 Alex McLeod 2020-06-16 12:34:06 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to '-'.

Comment 34 Leonid Natapov 2020-07-13 06:45:15 UTC
Basic collectd sanity was done.

Comment 36 errata-xmlrpc 2020-07-29 07:49:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3148