Bug 1410438

Summary: clock-applet segfaults
Product: Red Hat Enterprise Linux 6 Reporter: jigar <jraising>
Component: glib-networkingAssignee: Dan Winship <danw>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: high Docs Contact:
Priority: high    
Version: 6.9CC: aloughla, tlavigne, tpelka
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 2.28.6.1-2.4 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-21 09:02:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jigar 2017-01-05 13:46:45 UTC
Description of problem: clock-applet segfaults due to glib-networking.


Version-Release number of selected component (if applicable): glib-networking-2.28.6.1-2.2


Backtrace :

Core was generated by `/usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory -'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007fe2cf6b8a06 in g_tls_client_connection_gnutls_finish_handshake (conn=0x1784790, inout_error=0x0) at gtlsclientconnection-gnutls.c:352
352	  if (g_error_matches (*inout_error, G_TLS_ERROR, G_TLS_ERROR_NOT_TLS) &&
(gdb) bt
#0  0x00007fe2cf6b8a06 in g_tls_client_connection_gnutls_finish_handshake (conn=0x1784790, inout_error=0x0) at gtlsclientconnection-gnutls.c:352
#1  0x00007fe2cf6b9788 in handshake_internal (gnutls=0x1784790, blocking=<value optimized out>, cancellable=<value optimized out>, error=0x0) at gtlsconnection-gnutls.c:886
#2  0x00007fe2cf6bab71 in handshake_in_progress_or_failed (gnutls=0x1784790, blocking=1, cancellable=0x0, error=0x0) at gtlsconnection-gnutls.c:911
#3  close_internal (gnutls=0x1784790, blocking=1, cancellable=0x0, error=0x0) at gtlsconnection-gnutls.c:1094
#4  0x00007fe2cf6bb222 in g_tls_connection_gnutls_close (stream=<value optimized out>, cancellable=0x0, error=0x0) at gtlsconnection-gnutls.c:1114
#5  0x00007fe2e57a072c in g_io_stream_close (stream=0x1784790, cancellable=0x0, error=0x0) at giostream.c:428
#6  0x00007fe2e57a0766 in g_io_stream_dispose (object=<value optimized out>) at giostream.c:110
#7  0x00007fe2e550f70a in g_object_unref (_object=0x1784790) at gobject.c:2697
#8  0x00007fe2e2b7d9e2 in disconnect_internal (sock=0x17a8e50) at soup-socket.c:125
#9  0x00007fe2e2b7db3f in soup_socket_disconnect (sock=0x17a8e50) at soup-socket.c:1018
#10 0x00007fe2e2b5d8e8 in soup_connection_disconnect (conn=0x17c5f30) at soup-connection.c:597
#11 0x00007fe2e2b77d18 in soup_session_abort (session=<value optimized out>) at soup-session.c:1794
#12 0x00007fe2e4d9444a in weather_info_abort (info=0x16fd000) at weather.c:566
#13 0x0000000000418fab in update_weather_info (data=0x16b3870) at clock-location.c:682
#14 0x00007fe2e522908b in g_timeout_dispatch (source=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at gmain.c:3893
#15 0x00007fe2e5228642 in g_main_dispatch (context=0x168c040) at gmain.c:2441
#16 g_main_context_dispatch (context=0x168c040) at gmain.c:3014
#17 0x00007fe2e522cc98 in g_main_context_iterate (context=0x168c040, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3092
#18 0x00007fe2e522d1a5 in g_main_loop_run (loop=0x16d59b0) at gmain.c:3300
#19 0x00007fe2e5eec0f6 in bonobo_main () at bonobo-main.c:311
#20 0x00007fe2e5eea4d2 in bonobo_generic_factory_main_timeout (act_iid=<value optimized out>, factory_cb=<value optimized out>, user_data=<value optimized out>, 
    quit_timeout=<value optimized out>) at bonobo-generic-factory.c:411
#21 0x00007fe2e7f098c1 in panel_applet_factory_main_closure (iid=<value optimized out>, applet_type=23942384, closure=0x16d5650) at panel-applet.c:1774


Actual results: clock-applet segfaults due to glib-networking

Expected results: clock-applet shouldn't segfault

Additional info : This is high priority as customer's production system is affected.

Comment 1 Dan Winship 2017-01-05 15:37:07 UTC
Already fixed upstream long ago: https://git.gnome.org/browse/glib-networking/commit/?id=5f1fc91. Easily backported.

Comment 7 errata-xmlrpc 2017-03-21 09:02:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0567.html