Bug 1410510 (CVE-2016-10070)

Summary: CVE-2016-10070 ImageMagick: Out-of-bounds read in mat.c
Product: [Other] Security Response Reporter: Andrej Nemec <anemec>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: abhgupta, dmcphers, ethan, jhorak, jialiu, jokerman, kseifried, lmeyer, mmccomas, nmurray, pahan, sardella, slawomir, tiwillia
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ImageMagick 6.9.4 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-22 04:29:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1410515    
Bug Blocks: 1410453    

Description Andrej Nemec 2017-01-05 16:03:08 UTC
An out-of-bounds read vulnerability was found in ImageMagick in mat.c file. A maliciously crafted file could cause the application to crash.

Upstream bug:

https://github.com/ImageMagick/ImageMagick/issues/131

References:

http://seclists.org/oss-sec/2016/q4/758
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845246

Upstream patch:

https://github.com/ImageMagick/ImageMagick/commit/b173a352397877775c51c9a0e9d59eb6ce24c455

Comment 1 Andrej Nemec 2017-01-05 16:16:20 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1410515]