Bug 1410794

Summary: [RFE] Find Azure orchestration stack failure from its operations
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: ProvidersAssignee: Bill Wei <bilwei>
Status: CLOSED CURRENTRELEASE QA Contact: Jeff Teehan <jteehan>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.7.0CC: cpelland, jfrey, jhardy, obarenbo
Target Milestone: GAKeywords: FutureFeature, TestOnly, ZStream
Target Release: 5.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.8.0.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1410828 (view as bug list) Environment:
Last Closed: 2017-06-12 17:50:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1410828    

Description Satoe Imaishi 2017-01-06 14:16:11 UTC
From PR https://github.com/ManageIQ/manageiq/pull/12064:

Azure template deployment, aka orchestration stack, does not have an attribute for status message. For failed deployments, user needs to go through its operations, aka resources, to find out the causes.

Because of this reason, manageiq automate service currently simply shows provision failure without detailed error message. In the log the user is reminded to look into stack resources for reasons. QE often opened manageiq bugs when an Azure orchestration provisioning failed, but the actual failure happened on the provider side.

With this enhancement we scan through the operations and delegate the error message to the stack. So that the user will see clearly how the stack creation is failing.

The enhancement work is placed in a module. The code is meant to reused by the refresh logic. A follow-up PR will be created to use this module in fresh.

Comment 3 Jeff Teehan 2017-04-26 17:27:02 UTC
That is so much better.  fwiw, I never wrote a bug without checking the resources errors  :)  Moving to verified as of 5.8.0.12.  Copy of example test failure below.

Nice work Bill.

Error	Finished	426,000,000,000,001	Administrator	Service Provision	04/26/17 17:03:20 UTC	Provisioning Service [azprovone] from [azprovone]	Approved	Administrator	04/26/17 16:58:28 UTC	04/26/17 16:58:06 UTC	04/26/17 17:03:20 UTC	Auto-Approved	The supplied password must be between 8-123 characters long and must satisfy at least 3 of password complexity requirements from the following: 1) Contains an uppercase character 2) Contains a lowercase character 3) Contains a numeric digit 4) Con...

Added Polarion test case to tracker this moving forward.