Bug 1410897

Summary: Evolution cannot add a Google calendar
Product: Red Hat Enterprise Linux 7 Reporter: Trevin Beattie <tbeattie>
Component: evolutionAssignee: Milan Crha <mcrha>
Status: CLOSED NOTABUG QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2CC: debarshir, mbarnes, mcrha
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-09 11:15:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Trevin Beattie 2017-01-06 18:30:50 UTC
Description of problem:
I'm unable to add a Google calendar in Evolution.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create a new Calendar
2. Choose type “Google”, and enter your Google user name
3. Click on the Calendar button
4. Enter your Google password

Actual results:
“The requested resource was not found: https://developers.google.com/accounts/docs/AuthForInstalledApps”

Expected results:
Should show a list of my Google calendars

Additional info:
According to https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1459235 this was fixed in evolution-3.19.

Comment 2 Milan Crha 2017-01-09 11:15:47 UTC
Thanks for a bug report. The Google calendars require OAuth2 authentication, which the evolution 3.12.x doesn't support. The proper way to get to Google calendars (and address books and such) in this version is to use GNOME Online Accounts, which can be accessed through gnome-control-center. The newer version (3.20.0+) has integrated OAuth2 for the Google servers, but it's out of question to backport to 3.12.x.

Comment 3 Trevin Beattie 2017-01-09 15:39:30 UTC
Has Evolution 3.20 been built for RHEL 7?  `yum update' didn’t list any newer versions than 3.12; but then this server was created in Amazon AWS, and they might not be synced to the latest repository.

Comment 4 Milan Crha 2017-01-09 17:37:51 UTC
The evolution-3.12.11-22.el7 is the latest RHEL 7 version as of now. Some future updates of the RHEL 7 can provide newer versions, but the current situation is as it is.

Would the GNOME Online Accounts not work for you?

Comment 5 Trevin Beattie 2017-01-09 19:29:38 UTC
Gnome does not work on a headless Amazon EC2 instance; I had to switch it to use MATE instead.  The MATE Control Center doesn’t show “GNOME Online Accounts”, even though I have that package installed.

I can start the GNOME Control Center from a terminal, but the “Online Accounts” dialog is completely grayed out — the “Add an online account” button is disabled.

Comment 6 Milan Crha 2017-01-10 08:00:11 UTC
Weird. I've no problem running Online Accounts in other than GNOME desktop environment. Is /usr/libexec/goa-daemon runinng? It is usually started after login, but if it's not, then when the Online Accounts are opened then it is. I've no idea why the "Add an online account" button is disabled there.

I can give you what the
might look like with a Google account, but you'd still need to re-sign with it inside the gnome-control-center->Online Accounts to be able to use it.

Comment 7 Trevin Beattie 2017-01-11 16:12:44 UTC
I see both /usr/libexec/goa-daemon and /usr/libexec/goa-identity-service running.

It looks like the issue with Online Accounts was my fault.  I tried it again and found that it’s only disabled if I run it as root; I must not have been paying attention to that the other day.  I have it set up now.

Comment 8 Milan Crha 2017-01-11 17:01:16 UTC
Ah, good. I wouldn't think of such an issue. Good you figured it out.