Bug 1411506

Summary: [RFE] Tower integration should better log errors
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: ProvidersAssignee: Brandon Dunne <bdunne>
Status: CLOSED NEXTRELEASE QA Contact: Pavol Kotvan <pakotvan>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.6.0CC: bdunne, cpelland, dajohnso, jfrey, jhardy, obarenbo, simaishi
Target Milestone: GAKeywords: FutureFeature, ZStream
Target Release: 5.7.3   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: tower
Fixed In Version: 5.7.1.0 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1393941 Environment:
Last Closed: 2017-05-10 13:46:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1393941    
Bug Blocks:    

Comment 2 CFME Bot 2017-01-09 21:15:52 UTC
New commit detected on ManageIQ/manageiq/euwe:
https://github.com/ManageIQ/manageiq/commit/9aee1414552f8ed71f582ab482a4ace843bf13f1

commit 9aee1414552f8ed71f582ab482a4ace843bf13f1
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Dec 6 09:58:51 2016 -0500
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Mon Jan 9 16:12:21 2017 -0500

    Merge pull request #12996 from bdunne/update_ansible_tower_client
    
    Ensure AnsibleTowerClient.logger is set to $log not a NullLogger
    (cherry picked from commit db4e219440e133672e1cac422fb6f4096098b886)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1411506
    https://bugzilla.redhat.com/show_bug.cgi?id=1411507

 Gemfile                                                 | 2 +-
 app/models/manageiq/providers/ansible_tower/provider.rb | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comment 8 Brandon Dunne 2017-02-23 15:20:23 UTC
Pavol,

Sorry, this isn't working as expected.  It is logging the debug messages, but not very helpful with the error messages.  I have a new fix for that on the AnsibleTowerClient gem in https://github.com/ansible/ansible_tower_client_ruby/pull/72 but I don't think we want to backport all of the required changes to 5.7.z since this bug is a RFE.