Bug 1411647

Summary: Gui of many apps using Hardware acceleration suddenly freeze
Product: [Fedora] Fedora Reporter: Davide Repetto <red>
Component: xorg-x11-drv-atiAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-28 09:50:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Davide Repetto 2017-01-10 08:28:57 UTC
Description of problem:
=======================
The gui of apps which are using Hardware acceleration will suddenly freeze after a few seconds (or minutes) of usage, they will stop updating their content and stop responding to both mouse input and to the close button. Though most will still respond gracefully to a SIGHUP.

If the app is a media player the audio will carry on even though the video is frozen.

Apps that are hit by this are those which use some form of video acceleration or compositing. For examples those which use webkit with HW compositing enabled (even older versions of evolution where affected), most video players, Virtualbox, Steam, web browsers, many games etc. etc. 

All of the aforementioned problems will disappear when things are forced to run without hardware acceleration or when xorg-\* is replaced with the one from fc24.
In fact right now I'm using the following as a workaround:
dnf --releasever 24 downgrade xorg-x11-drv-ati --allowerasing

This problem will present itself on most (if not all) machines with [AMD/ATI] RS780L [Radeon 3000]

Version-Release number of selected component (if applicable):
=============================================================
xorg-x11-drv-ati-7.7.1-1.20160928git3fc839ff.fc25.x86_64

On the other hand one version that works for me is:
xorg-x11-drv-ati-7.6.1-3.20160215gitd41fccc.fc24.x86_64

How reproducible:
=================
Consistently, with the right hardware.

Steps to Reproduce:
===================
Please Note that I'm using MATE as a Desktop

1. Disable marco's software compositing / Disable Compiz
2. Run one of the named apps (I use MPV to test, because it usually freezes within the first minute or two)
3. Observe the freeze


Additional info:
===============
I also verified that the problem is reproducible on fedora 24 too, if you implant the xorg-x11 from fedora 25 as in:
dnf --releasever 25 upgrade xorg-x11\* --allowerasing


=============
The following is the config of a machine where I'm experiencing the problem: 

System:    Host: dave.idp.it Kernel: 4.8.15-300.fc25.x86_64 x86_64 (64 bit gcc: 6.3.1)
           Desktop: MATE 1.16.1  info: mate-panel dm: lightdm Distro: Fedora release 25 (Twenty Five)
Machine:   Device: desktop Mobo: ASUSTeK model: M5A78L-M/USB3 v: Rev X.0x serial: 130511331400634
           BIOS: American Megatrends v: 2101 date: 12/02/2014
CPU:       Dual core AMD Athlon II X2 250 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 12054
           clock speeds: min/max: 800/3000 MHz 1: 1800 MHz 2: 1800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS780L [Radeon 3000] bus-ID: 01:05.0 chip-ID: 1002:9616
           Display Server: X.org 1.18.4 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           tty size: 134x12 Advanced Data: N/A for root
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS780 HDMI Audio [Radeon 3000/3100 / HD 3200/3300]
           driver: snd_hda_intel bus-ID: 01:05.1 chip-ID: 1002:960f
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1002:4383
           Card-3 C-Media Audio Adapter (Planet UP-100 Genius G-Talk)
           driver: USB Audio usb-ID: 001-003 chip-ID: 0d8c:000e
           Sound: Advanced Linux Sound Architecture v: k4.8.15-300.red.fc25.x86_64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d800 bus-ID: 04:00.0 chip-ID: 10ec:8168
           IF: p10p1 state: up speed: 100 Mbps duplex: full mac: 74:d0:2b:79:ed:cf
Drives:    HDD Total Size: 1048.0GB (27.8% used)
Sensors:   System Temperatures: cpu: 41.0C mobo: 37.0C
           Fan Speeds (in rpm): cpu: 1849 sys-1: 0
Info:      Processes: 291 Uptime: 2:39 Memory: 4246.5/15793.8MB
           Init: systemd v: 231 runlevel: 5 default: graphical.target Gcc sys: 6.3.1
           Client: Shell (bash 4.3.431 running in s) inxi: 2.3.5


# glxinfo (abridged for brevity)
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD RS780 (DRM 2.46.0 / 4.8.15-300.red.fc25.x86_64, LLVM 3.8.0) (0x9616)
    Version: 13.0.3
    Accelerated: yes
    Video memory: 256MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RS780 (DRM 2.46.0 / 4.8.15-300.red.fc25.x86_64, LLVM 3.8.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.3
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 13.0.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

Comment 1 Davide Repetto 2017-02-28 09:50:05 UTC
the problem disappears with the current version of xorg.
Interestingly enough the ATI driver itself did not change, so the problem must have been somewhere else within xorg. 

xorg-x11-drv-ati-7.7.1-1.20160928git3fc839ff.fc25.x86_64
xorg-x11-server-common-1.19.1-3.fc25.x86_64
xorg-x11-server-utils-7.7-20.fc25.x86_64
xorg-x11-server-Xephyr-1.19.1-3.fc25.x86_64
xorg-x11-server-Xorg-1.19.1-3.fc25.x86_64
xorg-x11-server-Xvfb-1.19.1-3.fc25.x86_64
xorg-x11-utils-7.5-21.fc24.x86_64
xorg-x11-xauth-1.0.9-5.fc24.x86_64
xorg-x11-xbitmaps-1.1.1-9.fc24.noarch
xorg-x11-xinit-1.3.4-13.fc25.x86_64
xorg-x11-xkb-utils-7.7-17.fc24.x86_64