Bug 1411696

Summary: multiple NICs on provisioning network causes introspection failures
Product: Red Hat OpenStack Reporter: VIKRANT <vaggarwa>
Component: rhosp-directorAssignee: Angus Thomas <athomas>
Status: CLOSED WONTFIX QA Contact: Omri Hochman <ohochman>
Severity: medium Docs Contact:
Priority: medium    
Version: 10.0 (Newton)CC: aschultz, athomas, bfournie, cfields, cpaquin, cshastri, dbecker, dsneddon, jraju, mburns, morazi, rhel-osp-director-maint, spryor, vaggarwa
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-24 17:41:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description VIKRANT 2017-01-10 10:24:05 UTC
Description of problem:
multiple NICs on provisioning network causes introspection failures

Version-Release number of selected component (if applicable):
RHEL osp 10

How reproducible:
Everytime for Cu. 

Steps to Reproduce:
1. Start the introspection. 
2. Introspection is getting completed successfully. 
3. Showing different MAC address in following output in comparison to MAC address mentioned in instackenv.json file.

$ ironic node-port-list 

Actual results:
It's not picking the same MAC address which is mentioned in instackenv.json file. 

Expected results:
It should have pick the same MAC address. 


Additional info:
If we are disabling the other NICs on provisioning network. Introspection is getting successfully completed.

Comment 8 Chris Fields 2017-06-14 16:52:20 UTC
Can I get an update?  Is this being considered for a future OSP release?

Comment 10 Bob Fournier 2017-11-07 05:15:46 UTC
It looks like this is the same issue as BZ https://bugzilla.redhat.com/show_bug.cgi?id=1499268.  It has the same "No suitable interfaces found" error and we see the IP address being set to None for interfaces, e.g. u'eno56': {'ip': None, 'mac': u'00:17:a4:77:08:a6'}

Fix https://review.openstack.org/#/c/510125/ has been submitted to OSP-12 to increase the dnsmasq lease time which will prevent the IPA from re-requesting the address.

If you wanted to test a workaround you can increasing the dhcp lease time by editing /etc/ironic-inspector/dnsmasq.conf
and setting the last value in dhcp-range to 240, e.g.
change:
dhcp-range=10.8.146.100,10.8.146.120,29
to:
dhcp-range=10.8.146.100,10.8.146.120,10m

and restarting dnsmasq.

We also recommend only have one interface on the provisioning network which would remove the problem of lease timeouts.

Comment 11 Bob Fournier 2017-12-19 17:42:06 UTC
*** Bug 1243109 has been marked as a duplicate of this bug. ***

Comment 12 Bob Fournier 2018-03-21 19:59:29 UTC
Are you still seeing this issue? Have you tried either of the 2 workarounds in Comment 10?

Comment 14 Bob Fournier 2018-04-24 17:41:42 UTC
Closing this out for now with recommendation to have only one nic on the provisioning network.  If you do have multiple nics on the provisioning network increasing the dnsmasq lease time may help, as was suggested, and changed in OSP-12. There isn't a fix planned for backport to OSP-10.