Bug 1411788

Summary: satellite-capsule package does not oboslete capsule-installer
Product: Red Hat Satellite Reporter: Peter Ondrejka <pondrejk>
Component: PackagingAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED WONTFIX QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2.6CC: bkearney, ddolguik
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-08-02 20:59:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter Ondrejka 2017-01-10 13:43:50 UTC
Description of problem:

Upgrading the Satellite capsule from 6.1 to 6.2 according to steps from documentation: https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/installation-guide/#upgrading_capsule_server

In case the 6.1 capsule is not enabled as a pulp node, after changing the repositories to 6.2, yum update does not pull in the satellite-capsule package, which has to be installed manually.

Actual results:

~]# rpm -q --obsoletes satellite-capsule
pulp-nodes-parent  
pulp-nodes-child  
pulp-nodes-common  

Expected results:
-- should also obsolete capsule-installer

Comment 4 Bryan Kearney 2018-08-02 20:59:31 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.