Bug 1411892

Summary: Api examples in 6.2 docs are broken
Product: Red Hat Satellite Reporter: Tomas Strachota <tstrachota>
Component: Docs API GuideAssignee: Stephen Wadeley <swadeley>
Status: CLOSED CURRENTRELEASE QA Contact: Lucie Jirakova <ljirakov>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.2.6CC: swadeley, tstrachota
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-11 15:09:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
6.2 compatible ruby api example
none
6.2 compatible python api example none

Description Tomas Strachota 2017-01-10 16:54:20 UTC
Created attachment 1239157 [details]
6.2 compatible ruby api example

Document URL: 
https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/api-guide/42-api-examples-using-ruby
https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/api-guide/43-api-examples-using-python

Section Number and Name: 
4.2. API Examples Using Ruby
4.3. API Examples Using Python

Describe the issue: 
Scripts in both python and ruby fail to fetch id of the created organization.

Additional information: 
The examples were probably copied from 6.1 but the API has changed since then.

Suggestions for improvement: 
Please find the updated version of scripts attached. The current ruby script lacks comments, so I added some descriptions into the version I'm proposing.

Comment 1 Tomas Strachota 2017-01-10 16:54:51 UTC
Created attachment 1239158 [details]
6.2 compatible python api example

Comment 2 Stephen Wadeley 2017-01-11 08:03:02 UTC
Thank you for raising this bug and for the patch.

Comment 14 Stephen Wadeley 2017-01-11 15:09:07 UTC
Hello

These changes are now live on the customer portal.


Thank you.