Bug 1412254

Summary: 'NoMethodError' when creating a DialogFieldTagControl
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: UI - OPSAssignee: Jillian Tullo <jtullo>
Status: CLOSED CURRENTRELEASE QA Contact: Shveta <sshveta>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.7.0CC: hkataria, jhardy, mpovolny, obarenbo, sshveta
Target Milestone: GAKeywords: TestOnly, ZStream
Target Release: 5.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.8.0.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1412292 (view as bug list) Environment:
Last Closed: 2017-06-12 16:48:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1412292    

Description Satoe Imaishi 2017-01-11 15:53:23 UTC
From PR https://github.com/ManageIQ/manageiq/pull/13024:

When creating a DialogFieldTagControl, the options were not being symbolized. When returning the content of a DialogField, it was then raising a 'NoMethodError' because category was returning nil since it is looking for a symbolized category_id, not a string.

Comment 3 Shveta 2017-05-09 20:38:45 UTC
Fixed.
Verified in 5.8.0.13-rc2.20170502165848_0f98658