Bug 1412268

Summary: [python-setuptools] incorrect license
Product: [Fedora] Fedora Reporter: Carl George <carl>
Component: python-setuptoolsAssignee: Fedora Infrastructure SIG <infra-sig>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: infra-sig, kevin, lewk, mhroncok, randy, rkuska
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-06 17:53:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Carl George 2017-01-11 16:15:41 UTC
Setuptools has been relicensed under the MIT license.

https://github.com/pypa/setuptools/issues/132
https://github.com/pypa/setuptools/commit/d0bd7a5

As noted in that commit message, the bundled modules are under different licenses.  Since upstream version 26.1.0, there are four bundled modules.

packaging - BSD or ASL 2.0
pyparsing - MIT
six       - MIT
appdirs   - MIT

Please update the License tag in the spec file to reflect these changes.

Comment 1 Kevin Fenzi 2017-02-04 20:28:54 UTC
Will do. 

Note that as of http://setuptools.readthedocs.io/en/latest/history.html#v34-0-0 setuptools no longer bundles those modules.

Comment 2 Kevin Fenzi 2017-02-06 17:53:28 UTC
Fixed and mailed devel list on license change. 

Thanks for the note!