Bug 1412465

Summary: Router deployment failed due to error executing template
Product: OpenShift Container Platform Reporter: Gaoyun Pei <gpei>
Component: InstallerAssignee: Troy Dawson <tdawson>
Status: CLOSED CURRENTRELEASE QA Contact: Johnny Liu <jialiu>
Severity: medium Docs Contact:
Priority: high    
Version: 3.5.0CC: aos-bugs, jeder, jokerman, mifiedle, mmccomas, mnewby, wmeng
Target Milestone: ---Keywords: TestBlocker
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: aos-scalability-35
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-19 16:40:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gaoyun Pei 2017-01-12 05:19:25 UTC
Description of problem:
After ocp-3.5 env installation, router pod didn't get running.

Version-Release number of selected component (if applicable):
openshift3/ose-haproxy-router:v3.5.0.3

How reproducible:
always

Steps to Reproduce:
[root@gpei-test-35-master-1 ~]# oc get pod
NAME                       READY     STATUS             RESTARTS   AGE
router-1-7s67u             0/1       CrashLoopBackOff   6          7m
router-1-deploy            1/1       Running            0          8m

[root@gpei-test-35-master-1 ~]# oc logs router-1-7s67u
I0112 02:51:28.670582       1 router.go:229] Router is including routes in all namespaces
E0112 02:51:28.692136       1 ratelimiter.go:52] error executing template for file /var/lib/haproxy/conf/haproxy.config: template: haproxy-config.template:97:6: executing "/var/lib/haproxy/conf/haproxy.config" at <.BindPorts>: can't evaluate field BindPorts in type templaterouter.templateData
E0112 02:51:33.711318       1 ratelimiter.go:52] error executing template for file /var/lib/haproxy/conf/haproxy.config: template: haproxy-config.template:97:6: executing "/var/lib/haproxy/conf/haproxy.config" at <.BindPorts>: can't evaluate field BindPorts in type templaterouter.templateData


Actual results:


Expected results:


Additional info:

Comment 1 Scott Dodson 2017-01-12 14:36:33 UTC
Assigning to you Troy as I suspect that this is a problem with matching content in the docker images to the build but I'm not certain.

Comment 2 Mike Fiedler 2017-01-13 14:34:13 UTC
Raising severity to urgent since this blocks all testing requiring application traffic into the cluster.

Comment 3 Maru Newby 2017-01-13 16:45:05 UTC
Lowering the priority.  As per sdodson's comment, this is likely due to the binary and template in the image not being in sync.  A 3.5 binary will supply the BindPorts variable to the template.  Rebulding the router image to ensure a current 3.5 binary should fix the problem.

Comment 4 Troy Dawson 2017-01-13 18:36:40 UTC
The 3.5.0.3 images builds were pointing to the wrong (3.4) repository, so half of it's stuff was from 3.4, half from 3.5.
Todays build (v3.5.0.4) has this corrected and should work properly.
I'll update this bug when the images have finished building and are pushed for testing.

Comment 5 Troy Dawson 2017-01-13 20:47:19 UTC
v3.5.0.4 images have been created and pushed to testable areas.
Please let me know if this has been fixed.

Comment 6 Gaoyun Pei 2017-01-15 13:45:59 UTC
Test with openshift3/ose-haproxy-router:v3.5.0.4

Router pod was running well and no error shown in the log. Thanks for the fix!

Comment 7 Troy Dawson 2017-01-19 16:40:37 UTC
Since this was never released to customers, I am closing the bug.