Bug 1412772

Summary: Chromium installed a Chrome Web Store Payments application
Product: [Fedora] Fedora Reporter: Michael Catanzaro <mcatanzaro+wrong-account-do-not-cc>
Component: chromiumAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 25CC: tcallawa, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-31 17:32:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Catanzaro 2017-01-12 18:33:35 UTC
Description of problem: Chromium installs a Chrome Web Store Payments application. Applications in Fedora Workstation must be installable independently.


Version-Release number of selected component (if applicable): chromium-55.0.2883.87-1.fc25


How reproducible: Always


Steps to Reproduce:
1. Open GNOME Software
2. Install Chromium
3. Launch Chromium
4. Navigate to GNOME Shell overview

Actual results: Chrome Web Store Payments application is also installed


Expected results: No additional application is installed


Additional info: The Chrome Web Store Payments application does not work at all. No window appears when it is launched.

The desktop file chrome-nmmhkkegccagdldgiimedpiccmgmieda-Default.desktop seems to be created in my *home directory*. This functionality should be patched out of upstream Chromium as applications in Fedora Workstation must not created additional applications without user intervention. The contents of the desktop file are:

#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Terminal=false
Type=Application
Name=Chrome Web Store Payments
Exec=/usr/lib64/chromium-browser/chromium-browser.sh --profile-directory=Default --app-id=nmmhkkegccagdldgiimedpiccmgmieda
Icon=chrome-nmmhkkegccagdldgiimedpiccmgmieda-Default
StartupWMClass=crx_nmmhkkegccagdldgiimedpiccmgmieda

Yes, the desktop file includes a shebang. (Fortunately it's not executable.)

Comment 1 Tom "spot" Callaway 2017-08-31 17:32:15 UTC
I can't reproduce this. nmmhkkegccagdldgiimedpiccmgmieda is Google Wallet, but we definitely do not include it, and I do not see any code in Chromium which autodownloads it.

If you can reproduce this on a clean Fedora install, feel free to reopen.