Bug 1413735

Summary: OpenShift section not locked when a Deployment has been started
Product: Red Hat Quickstart Cloud Installer Reporter: Matt Reid <mreid>
Component: WebUIAssignee: John Matthews <jmatthew>
Status: NEW --- QA Contact: Sudhir Mallamprabhakara <smallamp>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 1.1CC: qci-bugzillas
Target Milestone: ---Keywords: Triaged
Target Release: 1.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Deployment was started
none
OpenShift section is still editable after Deployment has started none

Description Matt Reid 2017-01-16 20:37:24 UTC
Created attachment 1241400 [details]
Deployment was started

Description of problem:
Configurable content is supposed to become read-only once a deployment has started, but on a deployment I have that errored out (OpenShift has been deployed successfully, CFME had an issue), I can still adjust my type and other node details for OpenShift. 

Clearly, whatever I modify here will have no impact on anything, since the deployment has already been set up. To prevent any confusion, and be consistent with other sections, it should no longer be editable once the Deploy button has been pressed.

Version-Release number of selected component (if applicable):
1.1


Additional info:

Comment 2 Matt Reid 2017-01-16 20:37:55 UTC
Created attachment 1241401 [details]
OpenShift section is still editable after Deployment has started