Bug 141384

Summary: udev not picking up a multi-card reader
Product: [Fedora] Fedora Reporter: Paul F. Johnson <paul>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-03-13 11:28:51 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Paul F. Johnson 2004-11-30 15:50:18 EST
Description of problem:
I have a multicard reader which is plugged into an internal USB
socket. The card reader also has a floppy drive in it. /sbin/lsusb has
identified the card reader and there is an entry in
/proc/bus/usb/devices for it.

I have done a reset, it looks like something has been picked up as an
error message appears to say that there isn't an entry in fstab or
mtab for /proc/bus/usb

Version-Release number of selected component (if applicable):
udev 0.42-1
kernel 2.6.9-1.1004_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install the hardware
2. Reset
3.
  
Actual results:
Other than the error, nothing happens

Expected results:
The device should be installed with an icon in "Computer" with cards
automounted.

Additional info:
/proc/bus/usb/devices set as a file
Comment 1 Paul F. Johnson 2004-11-30 16:01:42 EST
Unable to attach the /proc/bus/usb/devices file as a file due to a
bugzilla problem (bug 141385)

Here it is as text!

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.9-1.1006_FC4 uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:1f.4
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=55aa ProdID=b012 Rev= 1.01
S:  Manufacturer= 
S:  Product=8-in-2  
S:  SerialNumber=D8C1CC9553
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=200mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms

The device is correctly identified, but nothing else happens.
Comment 2 Harald Hoyer 2004-12-01 06:04:35 EST
Driver=usb-storage should make a hotplug event (for debugging set in
/etc/sysconfig/hotplug: DEBUG="yes") and advertise /dev/sda or s.th.
like that... you may also turn on udev debugging (udev_log=yes in
/etc/udev/udev.conf).
Comment 3 Paul F. Johnson 2004-12-01 15:29:09 EST
/etc/sysconfig/hotplug didn't exist, so I've added it in. I'll reboot
shortly and report what happens.

Should /etc/sysconfig/hotplug exist?
Comment 4 Paul F. Johnson 2004-12-01 17:10:20 EST
On shut down, the message shutting down HAL came up as failed. On
reboot , I had no logging with either udev (nothing in /var/log or
/etc/udev) and had the same error on reboot of can't find
/proc/bus/usb in /etc/fstab or /etc/mtab.

Still using the 1006 kernel, the 1008 kernel gave an error on install
with --pre
Comment 5 Paul F. Johnson 2005-03-13 11:28:51 EST
This has been fixed in later kernels