Bug 1414545

Summary: Base Runtime FTBFS: itstool-2.0.2-4.fc24
Product: [Fedora] Fedora Reporter: Merlin Mathesius <mmathesi>
Component: itstoolAssignee: Matthias Clasen <mclasen>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 25CC: andrea.veri, klember, mclasen, psabata, sgallagh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: itstool-2.0.2-5.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-19 06:37:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1400162    
Deadline: 2017-02-01   
Attachments:
Description Flags
proposed patch to correct FTBFS issue none

Description Merlin Mathesius 2017-01-18 19:55:55 UTC
Description of problem:
When attempting to rebuild portions of the frozen package set of Fedora 25 for the Base Runtime effort, we discovered that itstool fails to build due to a missing BuildRequires on python due to python being removed from the default buildroot. This issue also manifests itself in Rawhide where only python3 is present in the buildroot.

Version-Release number of selected component (if applicable):
itstool-2.0.2-4.fc24

How reproducible:
Every time

Steps to Reproduce (rawhide):
1. fedpkg clone itstool
2. fedpkg switch-branch master
3. fedpkg mockbuild

Actual results (rawhide):

checking for python module libxml2... not found
configure: error: Python module libxml2 is needed to run this package

Actual results (base-runtime):

configure: error: no suitable Python interpreter found


Expected results:
Successful build of the package.

Additional info:
This is needed as part of the Base Runtime effort.

Attached is a patch that adds the missing BuildRequires on python.

Please apply the patch or respond with a reason it should not be applied within two weeks. After that time, a provenpackager will go ahead and apply it.

Comment 1 Merlin Mathesius 2017-01-18 19:57:57 UTC
Created attachment 1242275 [details]
proposed patch to correct FTBFS issue

Comment 2 Kalev Lember 2017-01-19 06:37:04 UTC
Thanks, applied the patch and building for rawhide. Do you need it for F25 too?

Comment 3 Merlin Mathesius 2017-01-19 13:51:42 UTC
Thank you for the quick fix! As long as the patch has been merged for F25 (which it is), we are good.

Comment 4 Kalev Lember 2017-01-19 13:55:20 UTC
OK, good!