Bug 141482

Summary: Unresolvable chain of dependencies
Product: [Fedora] Fedora Reporter: Need Real Name <lsof>
Component: krb5Assignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 3CC: bugs.michael
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-01-03 17:38:39 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2004-12-01 09:58:37 EST
# up2date krb5-workstation openssl-devel

[snip]

There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
krb5-devel-1.3.4-7                       requires krb5-libs = 1.3.4-7
Comment 1 Need Real Name 2004-12-13 05:22:32 EST
This dependency problem is preventing openssl-devel being installed.
Comment 2 Michael Schwendt 2005-01-03 00:29:00 EST
Not a bug. If you choose to update individual packages, you need to run

  up2date krb5-workstation krb5-devel openssl-devel

or

  up2date -u

to also update krb5-devel, which is installed on your machine. You
cannot update only krb5-workstation and krb5-libs without updating
krb5-devel, too. You try to break a dependency, and up2date refuses to
do that.
Comment 3 Need Real Name 2005-01-03 07:18:30 EST
I'm not trying to break a dependency. I want to install some packages,
and up2date should be resolving any dependencies.

Perhaps the rpms have their dependencies wrong.
Comment 4 Michael Schwendt 2005-01-03 07:35:02 EST
Watch this:

  $ rpm -qpR krb5-devel-1.3.4-7.i386.rpm | grep libs
  krb5-libs = 1.3.4-7

  $ rpm -qpR krb5-workstation-1.3.6-2.i386.rpm | grep \\-libs
  krb5-libs = 1.3.6-2

So, when you explicitly update only (!) krb5-workstation and
krb5-libs, you would break your installed krb5-devel-1.3.4-7. The
updated krb5-devel would suffice:

  $ rpm -qpR krb5-devel-1.3.6-2.i386.rpm | grep \\libs
  krb5-libs = 1.3.6-2

You need to tell up2date that you want to update krb5-devel, too, or
let up2date analyze your system and update everything that's installed.
Comment 5 Need Real Name 2005-01-03 11:31:39 EST
Your example shows yourself trying to install a particular version of
a downloaded rpm.

My bug report is about up2date not resolving dependencies when I ask
to install a non-version-specific package.
Comment 6 Michael Schwendt 2005-01-03 11:41:48 EST
False. My example does not install anything at all. It queries the
packages' dependencies to show why you must update krb5-devel, too, in
order to not break its dependencies. What's so hard to understand here?
Comment 7 Need Real Name 2005-01-03 15:57:11 EST
> Your example shows yourself _trying_ to install..
"False. My example does not install anything at all."

"What's so hard to understand here?"

Nothing, it's simple:
I asked up2date to fetch and install a package, and it didn't.
You say it's a dependency problem, I say up2date should handle it.

I'm not asking for a specific version of an rpm to be installed, I'm
asking for a version-inspecific package to be installed, and up2date
should do whatever it needs to resolve the dependencies.
Comment 8 Michael Schwendt 2005-01-03 16:59:18 EST
Even more interesting, I cannot reproduce it (contrary to what I
thought would happen, up2date behaves just like yum):

# up2date krb5-workstation openssl-devel

Fetching Obsoletes list for channel: fedora-core-3...

Fetching Obsoletes list for channel: updates-released-fc3...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
krb5-workstation                        1.3.6          2             
   i386  


Testing package set / solving RPM inter-dependencies...
########################################
krb5-workstation-1.3.6-2.i3 ########################## Done.         
         
krb5-libs-1.3.6-2.i386.rpm: ########################## Done.         
         
krb5-devel-1.3.6-2.i386.rpm ########################## Done.         
         
Preparing              ########################################### [100%]

Installing...
   1:krb5-libs             
########################################### [100%]
   2:krb5-workstation      
########################################### [100%]
   3:krb5-devel            
########################################### [100%]
The following packages were added to your selection to satisfy
dependencies:

Name                                    Version        Release
--------------------------------------------------------------
krb5-libs                               1.3.6          2             
     
krb5-devel                              1.3.6          2             
     

Comment 9 Need Real Name 2005-01-03 17:38:39 EST
Then they've updated a broken dependency. Closing.