Bug 1415360

Summary: F26+ drops drkonqi subpackage without obsoleting it (breaks upgrades)
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: plasma-workspaceAssignee: KDE SIG <kde-sig>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: jgrulich, jreznik, kde-sig, kevin, mbriza, me, rdieter, robatino, than
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-23 13:13:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1349186    

Description Adam Williamson 2017-01-21 02:27:08 UTC
Upgrades from F24 and F25 to Rawhide (F26) are currently broken because kde-runtime in F26 has dropped the drkonqi subpackage without obsoleting it:

http://pkgs.fedoraproject.org/cgit/rpms/kde-runtime.git/commit/?id=15667de6c5a7b73d63f6fdee20d144fba2b34895

this causes dependency errors when trying to upgrade without --allowerasing .

Comment 1 Adam Williamson 2017-01-21 02:28:15 UTC
Proposing as a Beta blocker, breaks upgrade of a release-blocking desktop (without --allowerasing). openQA hits this on every KDE upgrade test. Assigning to rdieter, since he made the offending change.

Comment 2 Kevin Kofler 2017-01-21 08:30:12 UTC
This should get obsoleted by the KF5 version, which will hopefully provide a compatibility symlink, unless kdelibs is going to get patched to use the correct path directly.

Comment 3 Rex Dieter 2017-01-22 18:26:26 UTC
Fyi, kdelibs is patched already, so no other hacks (like symlink) should be required

Comment 4 Kevin Kofler 2017-01-22 22:34:26 UTC
Well, you forgot kdelibs3, which was also patched to use /usr/libexec/kde4/drkonqi. I fixed it:
http://pkgs.fedoraproject.org/cgit/rpms/kdelibs3.git/commit/?id=f0b0934ee8495e38c53e3d8535af2c4cb252c696
but I need to sort out the OpenSSL situation before building it.

Comment 5 Kevin Kofler 2017-01-22 22:39:01 UTC
(Trying a build with compat-openssl10 for now, I'll look into backporting the Trinity changes for 1.1 separately.)

Comment 6 Rex Dieter 2017-01-23 13:13:28 UTC
I'm a little nervous about the (kde4) kde-runtime->drkonqi => plasma-workspace-drkonqi upgrade path, but I don't have any better alternative either (other than just adding Obsoletes to kde-runtime effectively nullifying upgrade path).

%changelog
* Mon Jan 23 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.8.5-4
- Obsoletes: kde-runtime (#1415360)