Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 141540

Summary: hard drive Geom failed on search. ( 20 gig dos partition: vfat type )
Product: [Fedora] Fedora Reporter: Ken Phillis Jr. <kphillisjr>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: medium    
Version: 3CC: pnasrat
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 14:07:25 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ken Phillis Jr. 2004-12-01 16:26:20 EST
Error message:
 Tracback (most recent call last):

File "/usr/src/build/475969-I386/install//usr/lib/anaconda/gui.py",
line 1074, in handleRenderCallback
     self.currentWindow.renderCallback()
File
"/usr/src/build/475969-I386/install//usr/lib/anaconda/iw/progress_gui.py",
line 242, in renderCallback
     self.intf.icw.nextClicked()
File "/usr/src/build/475969-I386/install//usr/lib/anaconda/gui.py",
line 789, in nextClicked
     self.dispatch.gotoNext()
File
"/usr/src/build/475969-I386/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
     self.moveStep()

File
"/usr/src/build/475969-I386/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
     rc = apply(func, self.bindArgs(args))

File
"/usr/src/build/475969-I386/install//usr/lib/anaconda/packages.py",
line 551, in turnOnFilesystems
     diskset.savePartitions()

File
"/usr/src/build/475969-I386/install//usr/lib/anaconda/dispatch.py",
line 715, in savePartitions()
     disk.commit()
error: Bug: Assertion((C * heads + H) * sectors + S == A) at
disk_dos.c:495 in function probe_partition_for_geom() failed.

Version-Release number of selected component (if applicable):
Fedora Core 3
How reproducible: over 10 for 10 tries.


Steps to Reproduce
1. Have 2 hard drives, 1 40 gig one, and one smaller one, like a 4 gig.
2. have the 40 gig drive separted into a 20 gig ntfs and a 20 gig Vfat
one ( u mbsing the windows installer)
3. go through the graphical installer for fedora core 3.
4. leave the 40 gig alone, and install to the smaller hard drive.
5. follow the installer as normal, it will error during the manual and
automatic partitioning. ( the error will be givin further below, as it
does eventually cause an Excepption Occured) ( I clicked ignore
repeatedly)( the error message is... """ Assertion ( sectors <=63 ) at
disk_dos.c:490 in function prob_partition_for_geom failed.""" )
5. select your packages ( does not matter what, use the default ones
you would use for a desktop)
6. continue through normally, and when you reach the page where it
starts to prepare the packages it will start to error repeatedly, and
click ignore each time and it will error with the exception occured.
  
Actual results:


Expected results:
it crashed and errored.

system specs:
Compaq Presorio
cpu: 700mhz
mem: 256 mb
vid card: 3dfx Voodoo3 ( generic system)
Comment 1 Jeremy Katz 2004-12-01 16:51:48 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.